Upgrade notices for 5.1.x

Upgrade your WackoWiki to 5.1.x.
Upgrade path is supported for 5.0.x
(If you upgrade from 5.0.beta or earlier, you have to upgrade to 5.0.x first! Find the instructions here.)


  1. Check ReleaseNotes for requirements
  2. Back up your files to save important data.
  3. Download the final version. wacko.5.1.0.zip

Preparations

  1. backup your old wacko folder
  2. back your wiki database (e.g. via phpMyAdmin)
  3. extract the new wacko.5.1.0.zip
  4. overwrite the old (wacko.5.0.0) wacko folder, except config/config.php
  5. delete the cached config under cache/config/config.php
  6. check permissions

Installer

Call the URI in your browser -> the installer starts and tell you (very IMPORTANT) that you are upgrading from 5.0.0 to 5.1.0

  • go through all steps

Captcha

To use Captcha, you must ensure that the session settings in freecap.php do not differ from the default values or your config settings,
else Captcha can't pass its values to the session. In the following link you find a workaround for this from our Development-Blog:

Notes

  1. Leave a comment here if something is not clear or you have further questions.
  2. Do not hesitate to improve this instructions and the wording.
  3. It is intended to remove all upgrade and legacy code prior to 5.0 after the upcoming release.