Upgrade notices for 5.4.x

Upgrade your WackoWiki to 5.4.x.
Upgrade path is supported for 5.0.x



  1. Check ReleaseNotes for requirements
  2. Back up your files to save important data.
  3. Download the final version. wacko.5.4.3.zip

Preparations

  1. backup
    1. your old wacko folder
    2. your wiki database (e.g. via phpMyAdmin or Admin Panel)
  2. extract the new wacko.5.4.0.zip
  3. overwrite the old (wacko.5.1.0) wacko folder, except config/config.php
  4. delete the cached config under cache/config/config.php
  5. check permissions

Installer

Call the URI in your browser -> the installer starts and tell you (very IMPORTANT) that you are upgrading from 5.1.0 to 5.4.0

  • go through all steps
  • Data base configuration: If the installer asks you for charset, select the appropriate character set, e.g. [cp1252 Western European] for Latin 1.

Captcha

To use Captcha, you must ensure that the session settings in freecap.php do not differ from the default values or your config settings,
else Captcha can't pass its values to the session. In the following link you find a workaround for this from our Development-Blog:

Notes

  1. Leave a comment here if something is not clear or you have further questions.
  2. Do not hesitate to improve this instructions and the wording.