View source for Testing

{{toc numerate=1}}

===Mode_Rewrite===

I used default settings
original .htaccess from R5.5 untouched
  * XAMPP deployed under ##/opt/lampp/##
  * httpd.conf ##LoadModule rewrite_module modules/mod_rewrite.so##
  * wacko config ##'base_url' => '~http://localhost/workspace/wackowiki-stable/wacko/',##

====ON====
%% LoadModule rewrite_module modules/mod_rewrite.so %%

##~http://localhost/workspace/wackowiki-stable/wacko/RecentlyCommented##

====OFF====

=====Site=====
%% #LoadModule rewrite_module modules/mod_rewrite.so %%

##~http://localhost/workspace/wackowiki-stable/wacko/?page=RecentlyCommented##

Works out of the box here!

------------------------------------------------
Please check your settings, it should work without 'index.php/'

Hint: You can't turn off the usage of mode_rewrite in the wacko config,
when the Settings class detects mode_rewrite is available, it will be turned ON

%% // if .htaccess tell us actual info on mod_rewrite status - use it
if (getenv('HTTP_MOD_ENV') === 'on')
{
$this->rewrite_mode = (getenv('HTTP_MOD_REWRITE') === 'on');
} %%

In other words, it should work with unchanged base_url and appends
'##?page=RecentlyCommented##' if mode_rewrite is OFF.

=====Admin panel=====

%% #LoadModule rewrite_module modules/mod_rewrite.so %%

##~http://localhost/workspace/wackowiki-stable/wacko/admin.php##

result -> 404

I got a 404. Seems there is a missing case / condition for routing admin.php
with ##_rewrite==0## in router.conf.

router.conf

%% `^admin\.php$` _ok! route=admin %%

index.php

%% case 'admin':
$config = & $db;
include 'admin/admin.php';
break; %%

Does someone see what's missing?
##wacko/admin/style/backend.css## gets routed

SOLUTION: ##/?page=admin.php##

=====Installer=====
-> OK

===News feed===
%%SELECT p.page_id, p.tag, p.title, p.created, p.body, p.body_r, p.comments, p.page_lang FROM doc_page p, doc_acl AS a WHERE p.page_id = a.page_id AND a.privilege = 'read' AND a.list = '*' AND p.comment_on_id = '0' AND p.noindex <> '1' AND p.deleted <> '1' AND p.tag REGEXP '^News/.+/.+/.+$' ORDER BY p.tag;%%

-> noindex NULL -> record fails

Missing Default Values after Upgrade
%% ALTER TABLE `wacko_page`
CHANGE `noindex` `noindex` tinyint(1) unsigned NULL DEFAULT '0' AFTER `disable_safehtml`; %%

%%UPDATE wacko_page SET noindex = '0' WHERE noindex IS NULL;%%

----
original is located at: ((/Dev/Release/R55/Testing))