SessionFileStore: inaccessible directory "/tmp"

Installed wacko, all successful until finally got error message:
SessionFileStore: inaccessible directory "/tmp" and blocked ("rien ne va plus")

– manually make new directory tmp + releasing rights
– opened config.php and looks fine

– 'wacko_version' => '5.5.8',
– locally, on xampp windows ApacheFriends XAMPP Version 7.2.4

What did I do wrong? Tnx in advance!


  1. Re: inaccessible directory "/tmp"

    You / xampp have probably insufficient user or access rights for the '/tmp' folder.

    Possible options:

    Change in constants.php the value for CACHE_SESSION_DIR to _cache/session

    define('CACHE_SESSION_DIR',		'/tmp');	// '_cache/session'

    Change in the secondary config / Admin panel System section the session_store value for Session handling from File (1) -> Database (2).

    Address your insufficient user or access rights for the '/tmp' folder.

    • WikiAdmin
    • 20.02.2019 09:52 edited
  2. A not working; C done; B= ??

    Tnx for suggestions:
    option A: done, but returned "SessionFileStore: inaccessible directory "/_cache/session""
    option C: done, all Windows permissions set to "allow" etc
    option B: cannot find file to edit, where exactly is it?

    Tnx again, ciao

  3. Re: session_store settings

    To A, same issue like C, set the necessary access rights for the folder /_cache/session and user (xampp).

    To B, you can change the value session_store either in the config table or via the Admin panel in the System section.

    AP change session store modi
    Change the session store modi from File to Database.

    D: Add some notes regarding session_store to the documentation where you think it belongs if you like.

    • WikiAdmin
    • 27.02.2019 16:29 edited