Mercurial Client


Every Mercurial repository is complete, self-contained, and independent. It contains its own private copy of a project’s files and history. A cloned repository remembers the location of the repository it was cloned from, but it does not communicate with that repository, or any other, unless you tell it to.


Fore more information about Mercurial see the official site.

1. Clients to work with Mercurial

1.1. Hg command line client

On a Linux system if/once the mercurial client is installed open a terminal and type hg --help .

1.2. TortoiseHg

You can use TortoiseHg for Windows or Linux PCs. The tool will be fully integrated in the Windows explorer.

1.3. MacHg

MacHg is a free open source OSX GUI for the revision control system Mercurial.

1.4. Eclipse

  • Donwload Eclipse Classic 4.7 (Oxygen) + PDT 5.0 + MercurialEclipse
  • "Help"->"Install New Software..."
    • select Oxygen – http://download.eclipse.org/releases/oxygen from the "Work with" drop down list
      • type "php" in the filter text
      • Select "PHP Development Tools (PDT) SDK Feature"
    • Name: MercurialEclipse
      • URL: https://bitbucket.org/mercurialeclipse/update-site/raw/default/
      • Screenshots and documentation
      • Note: [Windows] If SSH throws an error message, go to Window -> Preferences -> Team -> Mercurial and set Mercurial Executable to e.g. C:\Programme\TortoiseHg\hg.exe

1.4.1. optional Plugins

1.4.2. remarks

  • Unpack the Eclipse package in opt/ and create a starter for your desktop
  • Upgrade Eclipse in-place without reinstalling
    1. Go to Help > Install New Software… > Available Software Sites or Windows > Preferences > Install/Update > Available Software Sites
    2. Everywhere you see 4.6, press Edit and change it to 4.7. Similarly, change "neon" to "oxygen". For example, you should end up with at least these (if you don't have these, just add them):
      • http://download.eclipse.org/eclipse/updates/4.7
      • http://download.eclipse.org/releases/oxygen
    3. Note: you may also need to update other repositories
    4. Press OK, then go to Help > Check for Updates
  • Line endings: Please enforce LF
    1. Since Eclipse uses the platform’s line ending by default, source code written on Unix / Mac OS will use line feeds (LF), whereas Windows installations of Eclipse produce carriage returns AND line feeds (CRLF).
    2. Go to the preferences and select General -> Workspace. The New text file line delimiter determines which line ending is used for newly created files.
  • missing spell checker in Eclipse for PHP Developers: Installing JDT in Eclipse fixes the problem (the spell checking functionality is bundled with the JDT)
  • Setting the encoding per file via Edit -> Set Encodings... or per project Properties -> Resource and type or choose
    • Latin1 CP1252 (project default)
    • Greek CP1253
    • Cyrillic CP1251

1.5. NetBeans

https://netbeans.org/

2. More

Other tools that work with Mercurial