Dependencies

1. Requirements

1.1. PHP

PHP >= 7.0 (PHP 7.2 recommended)

1.1.1. PHP Extensions

  1. bcmath, or GMP
  2. ctype
  3. gd
  4. iconv
  5. json
  6. mbstring
  7. openssl
  8. pcre
  9. spl 

1.1.2. Necessity to raise the PHP version


PHP version

  • 5.4
    • short array syntax support
  • 5.5
    • password_hash() and password_verify() API 
  • 5.6
    • hashids 2.0 dropped PHP 5.3 – 5.5 support
  • 7.0
    • Null Coalescing Operator

cause for raise

1.2. Web server

Apache >= 2.2

1.3. Database

SQL database system, one of:

MariaDB >= 10
MySQL >= 5.6

2. Used Libraries


# directory project version status
1 bad_behavior Bad Behavior 2.2.22 patched: various, see repo
2 captcha freeCap 1.4.1 patched: various, see repo
3 htmlsax3 HTMLSAX3 3.0.0 patched: various, see repo
4 phpmailer PHPMailer 6.0.6 patched: various, see repo
5 phpthumb PhpThumb 2.1 unpatched
6 safehtml SafeHTML 1.3.7 patched: various, see repo
7 simplepie SimplePie 1.5.2 unpatched
8 text_highlighter Text_Highlighter 0.7.3 unpatched
9 hashids Hashids 3.0.0 patched, see subdir
10 php-diff php-diff 1.0 patched, see subdir

Upstream projects


3. Stack

4. Composer

  1. https://getcomposer.org/
  2. https://packagist.org/