View Issue Details

IDProjectCategoryView StatusLast Update
0000133WackoWikiadministrationpublic2010-02-02 03:11
ReporterTann San Assigned Toadministrator  
PrioritylowSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.2 
Target VersionFixed in Version 
Summary0000133: Let user choose names for non url-rewritten url
DescriptionSo at the moment urls are either

wakka.php?wakka=somepage

or

index.php?page=somepage

What we could do though is allow them to pick both the page name and the variable name during the wiki setup i.e.

wonga.php?howzit=somepage

We could store both in the config file to allow them to be easily changed later on.
TagsNo tags attached.

Relationships

related to 0000127 resolvedTann San change wakka.php?wakka= to index.php?page= 

Activities

administrator

2008-02-25 23:56

administrator   ~0000286

agree, can avoid a lot of anger

Tann San

2008-04-18 15:06

manager   ~0000319

This should not be a child of 0000156 as it's a totaly seperate issue.

Tann San

2008-06-09 09:20

manager   ~0000355

There is a problem with this. It's straight forward enough to handle in the index.php file but it's also used in the .htaccess file. I'm not sure how to go about handling this. I think we should take this off the roadmap and make it a hack/patch. The process is pretty simple to do, it only takes 3 line changes (I think without further testing).

administrator

2010-02-02 03:11

administrator   ~0000739

guess we can drop this issue since base_url is now equal for both cases and Wacko uses ?page if mode_rewrite is off

pls. reopen if necessary

Issue History

Date Modified Username Field Change
2007-12-01 15:28 Tann San New Issue
2007-12-01 15:28 Tann San Legacy => NEW
2008-02-25 23:56 administrator Note Added: 0000286
2008-02-25 23:56 administrator Status new => acknowledged
2008-02-25 23:56 administrator Target Version => 5.0.0
2008-04-18 15:06 Tann San Note Added: 0000319
2008-05-15 09:51 Tann San Status acknowledged => assigned
2008-05-15 09:51 Tann San Assigned To => Tann San
2008-06-09 09:20 Tann San Note Added: 0000355
2008-06-09 11:14 administrator Target Version 5.0.0 =>
2009-10-13 12:21 Tann San Assigned To Tann San =>
2009-12-11 20:08 administrator Relationship added related to 0000127
2010-02-02 03:11 administrator Note Added: 0000739
2010-02-02 03:11 administrator Assigned To => administrator
2010-02-02 03:11 administrator Status assigned => resolved
2010-02-02 03:11 administrator Resolution open => fixed
2010-03-08 10:09 administrator Category Administration => administration