View Issue Details

IDProjectCategoryView StatusLast Update
0000186WackoWikiactionpublic2011-02-16 13:03
ReporterTann San Assigned Toadministrator  
Status resolvedResolutionno change required 
Product Version4.2 
Summary0000186: Rename Actions as Plugins
DescriptionActions are really plugins so it makes more sense to have them named that way. Inside the Actions (aka Plugins) directory we can have a "Core" directory which holds all the default plugins. We maintain a list of those in the main index.php or wacko class file. Then we have a either one directory for all 3rd party plugins or one directory for each plugin.

This will let us differentiate between Hacks n Patches and Plugins. The idea is that a plugin is simply something that requires one or more files in the Plugins directory. A "Hack/Patch" is something that requires modification of various system files such as the index.php or main wacko class.

This then leads to us implementing a plugin installation/removal system further down the road via the (yet to be created) admin interface.
TagsNo tags attached.



2008-07-02 14:19

administrator   ~0000402

Move items not related to the core of the wiki out of wacko.class.php (ie. Forms, Users, DB, Referrers, Comments, etc.). The core should only be for loading actions, handlers, formatters, etc. All of these items should be offloaded into autoloading plugins.


2008-07-26 17:35

administrator   ~0000438

Actions (depend on the core) > Plugins / AddOns (self sustained)

Issue History

Date Modified Username Field Change
2008-06-30 09:55 Tann San New Issue
2008-06-30 09:55 Tann San Legacy => NEW
2008-07-02 14:19 administrator Note Added: 0000402
2008-07-26 17:35 administrator Note Added: 0000438
2010-03-08 10:09 administrator Category Action => action
2011-02-16 11:44 administrator Status new => resolved
2011-02-16 11:44 administrator Resolution open => no change required
2011-02-16 13:03 administrator Assigned To => administrator