View Issue Details

IDProjectCategoryView StatusLast Update
0000259WackoWikiinstallerpublic2013-07-29 02:30
Reporteradministrator Assigned Toadministrator  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.2 
Target Version5.4.0Fixed in Version5.4.0 
Summary0000259: incorrect CSS Path in installer with mode_rewrite
DescriptionStylesheet http://test.wackowiki.org/HomePagesetup/css/installer.css/ wurde nicht geladen, weil sein MIME-Typ, "text/html", nicht "text/css" ist.


error
/HomePagesetup/ (false)
/setup/ (ok)
Steps To Reproduceupgrade with mode_rewrite=1

<?php echo myLocation() ?>setup/css/installer.css" type="text/css" />

<link rel="shortcut icon" href="<?php echo myLocation() ?>setup/favicon.ico" type="image/x-icon" />

probably function myLocation() needs a fix for the rewrite case
TagsNo tags attached.

Relationships

related to 0000399 resolvedadministrator Installation Severely Broken on IIS 7.5 

Activities

Tann San

2009-04-09 09:35

manager   ~0000617

Might be fixed in latest SVN release. I'll test it myself later this week but if anyone else feels like giving it a go in the mean time, feel free...

administrator

2009-10-14 19:06

administrator  

WackoWiki Installation.png (19,204 bytes)   
WackoWiki Installation.png (19,204 bytes)   

administrator

2009-10-14 19:36

administrator   ~0000711

ebal reported the same problem

Tann San

2009-10-14 20:21

manager   ~0000712

I think the problem is because you are accessing the installer when viewing it from a different location. It's easier to explain with an example. Say you have a page called AnimalTypes in the wiki so you go to:

www.yoursite.com/AnimalTypes

If the wiki isn't setup yet then it tries to start the installer:

www.yoursite.com/AnimalTypes?installAction=version-check

In this case it's trying to find the installer files inside the AnimalTypes directory. I think the fix for this is to use an absolute path when we start the installer process. I'll have a look into this tomorrow if I have time. I think the place to look is init.php.

It should be noted that this doesn't occur if you look at it in the proper (mod_rewrite) location:

www.yoursite.com?installAction=version-check

AndyM84

2011-10-01 20:46

updater   ~0000813

I had a similar issue I reported, didn't find this until after reporting (sorry!). The issue is 0000397, and it's something to do with mod_rewrite for me.

administrator

2013-01-20 23:59

administrator   ~0000882

Last edited: 2013-02-24 04:39

View 4 revisions

The mess is created when $_SERVER['REQUEST_URI'] is call with mode_rewrite on

just for testing -> replace the following line in config.default.php 'base_url' => [..]

preg_replace('/(\?|&)installAction=site-config/','',$_SERVER['REQUEST_URI']),

with

'/'.preg_replace('/\/\//', '\/', trim(strtr(dirname($_SERVER['SCRIPT_NAME']), '\\', '/'), '/')) ,

Feedback welcome.

administrator

2013-02-24 04:40

administrator   ~0000888

commit: http://wackowiki.hg.sourceforge.net/hgweb/wackowiki/dev/rev/292725f72e08

administrator

2013-07-29 02:17

administrator   ~0000896

Last edited: 2013-07-29 02:30

View 3 revisions

test patch with additional slash to fix the following:
http://localhost/wacko_work/wackosetup/css/installer.css
to
http://localhost/wacko_work/wacko/setup/css/installer.css

config_defaults.php:

'/'.preg_replace('/\/\//', '\/', trim(strtr(dirname($_SERVER['SCRIPT_NAME']), '\\', '/'), '/')).'/' ,

Issue History

Date Modified Username Field Change
2009-01-19 00:32 administrator New Issue
2009-01-19 00:37 administrator Target Version => 5.0.0
2009-01-19 00:37 administrator Steps to Reproduce Updated
2009-01-19 00:38 administrator Status new => confirmed
2009-01-19 00:39 administrator Description Updated
2009-01-19 00:39 administrator Steps to Reproduce Updated
2009-01-19 00:45 administrator Summary incorrect CSS Path in installer => incorrect CSS Path in installer with mode_rewrite
2009-04-09 09:30 Tann San Status confirmed => assigned
2009-04-09 09:30 Tann San Assigned To => Tann San
2009-04-09 09:35 Tann San Note Added: 0000617
2009-04-09 09:35 Tann San Status assigned => feedback
2009-04-10 15:16 Tann San Status feedback => resolved
2009-04-10 15:16 Tann San Fixed in Version => 5.0.0
2009-04-10 15:16 Tann San Resolution open => fixed
2009-10-13 15:58 administrator Target Version 5.0.0 => 5.0.beta
2009-10-13 16:03 administrator Fixed in Version 5.0.0 => 5.0.beta
2009-10-14 19:06 administrator File Added: WackoWiki Installation.png
2009-10-14 19:36 administrator Note Added: 0000711
2009-10-14 19:36 administrator Status resolved => feedback
2009-10-14 19:36 administrator Resolution fixed => reopened
2009-10-14 20:21 Tann San Note Added: 0000712
2009-10-14 23:22 administrator Assigned To Tann San => administrator
2010-03-08 10:14 administrator Category Installer => installer
2011-05-31 23:21 administrator Target Version 5.0.beta => 5.0.rc
2011-09-12 11:56 administrator Fixed in Version 5.0.beta => 5.0.0
2011-09-12 11:56 administrator Fixed in Version 5.0.0 =>
2011-09-12 11:56 administrator Target Version 5.0.rc => 5.0.0
2011-10-01 20:46 AndyM84 Note Added: 0000813
2011-10-18 14:42 administrator Relationship added related to 0000399
2012-04-22 17:04 administrator Target Version 5.0.0 => 5.4.0
2013-01-20 23:59 administrator Note Added: 0000882
2013-01-20 23:59 administrator Status feedback => assigned
2013-01-21 00:02 administrator Note Edited: 0000882 View Revisions
2013-01-21 00:03 administrator Note Edited: 0000882 View Revisions
2013-02-24 04:39 administrator Note Edited: 0000882 View Revisions
2013-02-24 04:40 administrator Note Added: 0000888
2013-02-24 04:40 administrator Status assigned => resolved
2013-02-24 04:40 administrator Resolution reopened => fixed
2013-02-24 04:40 administrator Fixed in Version => 5.4.0
2013-07-29 02:17 administrator Note Added: 0000896
2013-07-29 02:18 administrator Note Edited: 0000896 View Revisions
2013-07-29 02:30 administrator Note Edited: 0000896 View Revisions