View Issue Details

IDProjectCategoryView StatusLast Update
0000115WackoWikiformatterpublic2009-08-19 09:38
Reporteradministrator Assigned ToTann San  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Target Version4.3.rcFixed in Version4.3.rc 
Summary0000115: var dbclick = "page";
Descriptioncaused by ... (?)

this happens if you store lots of text (size) in a page, then you got at the end of the stored page:

var dbclick = "page";

full text is then only accessible via EDIT

http://test.wackowiki.org/Bugs/115





Steps To Reproducesee also 0000168
Additional InformationHotfix (only for experienced users, side effects!)

ALTER TABLE `wacko_pages`
CHANGE `body` `body` MEDIUMTEXT NOT NULL ,
CHANGE `body_r` `body_r` MEDIUMTEXT NOT NULL

ALTER TABLE `wacko_revisions`
CHANGE `body` `body` MEDIUMTEXT NOT NULL ,
CHANGE `body_r` `body_r` MEDIUMTEXT NOT NULL


TEXT: 2^16–1 -> 64 kB
MEDIUMTEXT: 2^24–1 -> 16,4 MB
TagsNo tags attached.

Relationships

related to 0000181 resolvedadministrator Formatter fails under some circumstances and produces a blank page 
related to 0000251 resolvedpascalvmf upgrade fails in alter_revisions due to a typo (fix included) 
child of 0000168 resolvedTann San pagesize issue - missing indication for oversized input 

Activities

Tann San

2007-12-01 15:34

manager   ~0000221

<kirk>need ... more ... info</kirk>

administrator

2007-12-02 14:36

administrator   ~0000228

will post another example, when found

2008-05-02 14:46

 

administrator

2008-05-02 14:47

administrator   ~0000323

Last edited: 2008-08-23 14:20

example found:
http://wackowiki.org/RobertVaeth/ThemeDepot/BlueNatic/CSSFiles

Tann San

2008-06-17 02:51

manager   ~0000374

The problem seems to be in the paragrafica formatting class files. If you open classes/wacko.php and search for the SavePage function there are two lines in there:

$body_r = $this->Format($body_r, "paragrafica");

If you comment those out it no longer applies the paragrafica formatting to the body_r data before saving it to SQL. When you re-view the page it displays in full.

A quick fix is to just comment out the two occurences of the line I just posted. A better fix would be to identify what (inside the paragrafica files) is causing it to break. It's like 4am here now though so I think I've spent enough time on Wacko today/night.

Tann San

2008-06-17 03:11

manager   ~0000375

Last edited: 2008-08-23 14:21

scrap that, I tracked it down to the column size in SQL. I didn't test out the recommended fix in the child issue:

0000168

I implemented it, did a crap test and then undid it thinking it didn't fix it. Later realised what the real problem was and that it just didn't work because my test was stupid.

I've commited it as a possible fix. Works for me. Needs to re-installed/updated for the changes to take effect.

Tann San

2008-06-17 03:14

manager   ~0000376

If this works for everyone then I suggest we close the child issue as well. The "Hotfix" supercedes the "warn the user if they exceed the limit" thing since it's more likely that their server will timeout writing the page.

ok 04:15am on a weeknight, I'm done :¬)

administrator

2008-06-17 04:05

administrator   ~0000377

Last edited: 2008-06-17 04:07

you hit the dilemma, now we need a solution for the timeout issue, some (should I say most?) have no glue - belive me - they will post 20MB text at once - how do other projects handle this?

a similar issue is the file upload, explain an ordinary user short in his terms why he cant upload his 50MB slide show file - good luck

so we need at least a idiot proof mechanism which warn and prevents data loss
while the scenarios can differ, we got broadband and intranet users on the one hand and shared hosting & limited upload on the other

Tann San

2008-06-17 12:41

manager   ~0000378

I think for now we roll with the solution we have and count the timeout issue as a fresh bug to track in a future version. I think we need to spend some time seriously thinking about our options here.

Tann San

2008-06-18 09:58

manager   ~0000379

Increased SQL column to MediumText

administrator

2008-11-22 23:34

administrator   ~0000535

Last edited: 2009-01-08 10:03

the update script changed only the value for body for revisions, need to run more tests

ALTER TABLE `wacko_revisions`
CHANGE `body` `body` MEDIUMTEXT NOT NULL ,
CHANGE `body_r` `body_r` MEDIUMTEXT NOT NULL

for some reason body_r won't get updated
-> install and update script may be needs to be changed accordingly

Error and Fix: -> 0000251

Issue History

Date Modified Username Field Change
2007-10-17 15:43 administrator New Issue
2007-10-17 15:43 administrator Legacy => NEW
2007-12-01 15:34 Tann San Note Added: 0000221
2007-12-01 15:34 Tann San Status new => feedback
2007-12-02 14:13 administrator Description Updated
2007-12-02 14:36 administrator Note Added: 0000228
2008-05-02 14:46 administrator File Added: WackoWiki - RobertVaeth-ThemeDepot-BlueNatic-CSSFiles.png
2008-05-02 14:47 administrator Note Added: 0000323
2008-05-12 02:54 administrator Relationship added related to 0000168
2008-05-19 22:23 administrator Description Updated
2008-06-17 02:51 Tann San Note Added: 0000374
2008-06-17 03:11 Tann San Note Added: 0000375
2008-06-17 03:14 Tann San Note Added: 0000376
2008-06-17 04:05 administrator Note Added: 0000377
2008-06-17 04:07 administrator Note Edited: 0000377
2008-06-17 12:41 Tann San Note Added: 0000378
2008-06-18 09:56 Tann San Relationship deleted related to 0000168
2008-06-18 09:57 Tann San Relationship added child of 0000168
2008-06-18 09:58 Tann San Status feedback => resolved
2008-06-18 09:58 Tann San Resolution open => fixed
2008-06-18 09:58 Tann San Assigned To => Tann San
2008-06-18 09:58 Tann San Note Added: 0000379
2008-06-18 09:58 Tann San Fixed in Version => 5.0.0
2008-06-28 18:34 administrator Steps to Reproduce Updated
2008-08-23 14:20 administrator Description Updated
2008-08-23 14:20 administrator Note Edited: 0000323
2008-08-23 14:21 administrator Note Edited: 0000375
2008-08-23 14:21 administrator Note Edited: 0000375
2008-08-31 18:37 administrator Fixed in Version => 5.0.0
2008-08-31 18:37 administrator Target Version => 5.0.0
2008-10-13 11:00 administrator Additional Information Updated
2008-10-13 18:00 administrator Relationship added related to 0000181
2008-11-22 23:34 administrator Note Added: 0000535
2008-11-22 23:51 administrator Additional Information Updated
2008-11-22 23:54 administrator Note Edited: 0000535
2008-11-23 00:36 administrator Note Edited: 0000535
2008-11-23 00:36 administrator Note Edited: 0000535
2008-11-23 00:38 administrator Note Edited: 0000535
2009-01-08 10:03 administrator Relationship added related to 0000251
2009-01-08 10:03 administrator Note Edited: 0000535
2009-08-19 09:25 administrator Fixed in Version 5.0.0 => 4.3.rc
2009-08-19 09:38 administrator Target Version 5.0.0 => 4.3.rc
2010-03-08 10:13 administrator Category Formatter => formatter