View Issue Details

IDProjectCategoryView StatusLast Update
0000181WackoWikiformatterpublic2012-09-27 04:56
Reporteradministrator Assigned Toadministrator  
PriorityhighSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.2 
Target Version5.0.betaFixed in Version5.0.beta 
Summary0000181: Formatter fails under some circumstances and produces a blank page
Descriptionor cuts the text at the end of the page
while the full text is available via Edit
no body_r

fail also with R4.2, not new

see attached examples (more to come)

Mostly this error appears while past and copy text / articels from an other source into the Wiki.
HOTFIX: place the text inside %%paste here%% tags meanwhile

Steps To Reproducehttp://test.wackowiki.org/Bugs/181?show_comments=1#comments

Additional Informationthe conflict is possibly caused by a “wrong” combination of
"


in a line -> RegExp issue

HOTFIX: /formatters/classes/typografica.php (line 65)

change
"laquo" => 1, // angle quotes
"quotes" => 1,
to
"laquo" => 0, // angle quotes
"quotes" => 0,
TagsNo tags attached.

Relationships

related to 0000099 resolvedTann San Ukrainian language for formatter typografica 
related to 0000115 resolvedTann San var dbclick = "page"; 
related to 0000168 resolvedTann San pagesize issue - missing indication for oversized input 
related to 0000286 acknowledged "laquo" => 1 and "quotes" => 1, causes in some cases the Formatter to fail 
related to 0000303 resolvedadministrator Formatter fails in combination with the include action 
related to 0000428 closed Lost content on editing 
child of 0000285 resolvedadministrator Certain text causes page to disappear 

Activities

2008-06-20 08:30

 

2008-06-21 20:14

 

testcase_bug181.txt (1,345 bytes)   
%%(wacko wrapper="box" wrapper_width="400")"Contrary to their reputation, Wikis are content management systems that can be managed. They simply take a different approach to content management by choosing to emphasize speed and flexibility rather than strict controls. In order to successfully implement a wiki software package you will need to look at workflow from a different perspective and be sure to select wiki software that provides the right level of content monitoring and access control for your organization." -- ((http://www.cmswatch.com/Feature/145-Wikis-in-the-enterprise What makes an enterprise wiki?))%%

Wikis werden als Werkzeuge zum ((http://en.wikipedia.org/wiki/Knowledge_Management "Wissensmanagement")) eingesetzt. Sie sind einfacher und schneller zu nutzen als herk�mmliche ((http://en.wikipedia.org/wiki/Content_management_system Content-Management-Systeme (CMS))). Wikis bilden die Basis zum Abbilden von (zun�chst) unstrukturierten Informationen. Im Gegensatz zu B�roanwendungssoftware ben�tigt man keine spezielle Software auf den Arbeitsplatzrechnern. Mittels Web-Browser und in das Wiki integrierten Text-Editor kann man Inhalte bearbeiten. Aus Anwendersicht sind Wikis Webseiten die ohne spezielle HTML-Kenntnisse genutzt werden k�nnen, um Wissen gemeinsam mit anderen Nutzern zu erzeugen und bereit zu stellen.
testcase_bug181.txt (1,345 bytes)   

administrator

2008-06-30 11:05

administrator   ~0000389

Last edited: 2008-10-23 15:28

we can pass this issue to 4.4 since it seems that this is an old flaw or introduced with PHP5.x

it would be appreciated if someone can look closer into this - possibly we can still include a fix for this in the upcoming release

administrator

2008-08-02 21:02

administrator   ~0000458

Last edited: 2009-01-06 17:20

new cases
http://wackowiki.org/Dev/WackoIdeas
http://test.wackowiki.org/Abram4?show_comments=1#comments
http://wackowiki.org/TimoshenkoMixail

page content only accessible via [Edit]

administrator

2009-03-23 16:57

administrator   ~0000613

Last edited: 2009-03-24 08:59

empty body_r -> WackoFormatter failed

caused by "laquo" => 1, and "quotes" => 1,

FIX:
short term - set value 0 [rev338]
long term - ...

Issue History

Date Modified Username Field Change
2008-06-11 21:08 administrator New Issue
2008-06-11 21:08 administrator Legacy => NEW
2008-06-11 22:09 administrator Steps to Reproduce Updated
2008-06-11 23:33 administrator Additional Information Updated
2008-06-20 08:30 administrator File Added: TestSite - Bugs - 181 (edit).png
2008-06-21 19:12 administrator Relationship added related to 0000099
2008-06-21 20:11 administrator Steps to Reproduce Updated
2008-06-21 20:12 administrator Steps to Reproduce Updated
2008-06-21 20:14 administrator File Added: testcase_bug181.txt
2008-06-25 15:03 administrator Description Updated
2008-06-26 12:30 administrator Description Updated
2008-06-30 11:05 administrator Note Added: 0000389
2008-06-30 11:06 administrator Target Version 5.0.0 => 5.4.0
2008-08-02 21:02 administrator Note Added: 0000458
2008-08-23 14:00 administrator Note Edited: 0000458
2008-08-23 14:00 administrator Steps to Reproduce Updated
2008-10-13 18:00 administrator Relationship added related to 0000115
2008-10-13 18:01 administrator Note Edited: 0000389
2008-10-13 18:02 administrator Note Edited: 0000458
2008-10-13 18:15 administrator Status new => acknowledged
2008-10-13 22:32 administrator Note Edited: 0000458
2008-10-23 15:17 administrator Note Edited: 0000458
2008-10-23 15:25 administrator Description Updated
2008-10-23 15:28 administrator Note Edited: 0000389
2008-10-23 15:32 administrator Relationship added related to 0000168
2008-10-24 09:08 administrator Description Updated
2008-10-24 09:08 administrator Additional Information Updated
2008-11-22 15:07 administrator Description Updated
2008-11-22 15:07 administrator Description Updated
2009-01-06 17:20 administrator Note Edited: 0000458
2009-03-23 10:09 administrator Target Version 5.4.0 => 5.0.0
2009-03-23 10:10 administrator Relationship added child of 0000285
2009-03-23 16:57 administrator Note Added: 0000613
2009-03-23 16:57 administrator Assigned To => administrator
2009-03-23 16:57 administrator Status acknowledged => resolved
2009-03-23 16:57 administrator Resolution open => fixed
2009-03-23 16:57 administrator Product Version => 4.2
2009-03-23 16:57 administrator Fixed in Version => 5.0.0
2009-03-23 16:57 administrator Summary Formatter seems to fail under some circumstances and produces blank page => Formatter fails under some circumstances and produces blank page
2009-03-23 16:57 administrator Additional Information Updated
2009-03-23 17:04 administrator Summary Formatter fails under some circumstances and produces blank page => Formatter fails under some circumstances and produces a blank page
2009-03-23 17:12 administrator Issue cloned: 0000286
2009-03-23 17:12 administrator Relationship added related to 0000286
2009-03-24 08:58 administrator Additional Information Updated
2009-03-24 08:59 administrator Note Edited: 0000613
2009-06-26 17:36 administrator Relationship added related to 0000303
2009-10-13 15:58 administrator Target Version 5.0.0 => 5.0.beta
2009-10-13 16:03 administrator Fixed in Version 5.0.0 => 5.0.beta
2010-03-08 10:13 administrator Category Formatter => formatter
2011-05-31 21:24 administrator Build => R5.0.beta
2012-09-27 04:56 administrator Relationship added related to 0000428