View Issue Details

IDProjectCategoryView StatusLast Update
0000284WackoWikiwikieditpublic2019-10-14 10:33
Reporterediworld Assigned Toadministrator  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.x 
Target Version6.0.xFixed in Version6.0.beta1 
Summary0000284: WikiEdit does not show buttons bar when charset /language is Estonian/Polish
DescriptionR43 WikiEdit does not show buttons bar when charset /language is not English/Russian.

Reproducibility:
Create wiki test page. Click on link "Settings". Change "language of this page" to PL (Polish) or ET (Estonian). Click "Save". Doubleclick to edit page. WikiEdit buttons bar has dissapeared.
Steps To ReproduceChange "language of this page" to EN (English) or RU (Russian). Click Save". Doubleclick to edit page. WikiEdit buttons bar is back again.

Anoying bug - everything was ok in R42.

The same happens when you edit /lang/lang.en.php and change the charset:
for example to "charset" => "windows-1257". WikiEdit buttons are dissapearing then from english version as well.
Additional Informationhttp://test.wackowiki.org/Bugs/284 <- test yourself

HOTFIX: disable Autocomplete under user settings -> extended -> Complete wikilinks by Ctrl+Space
TagsNo tags attached.

Relationships

related to 0000238 resolvedadministrator lang.et.php or lang.pl.php-> "Invalid Range in character class". -> JavaScript. 

Activities

administrator

2009-03-22 16:28

administrator   ~0000610

Last edited: 2009-03-22 16:43

lang.et.php -> "Invalid Range in character class". -> JavaScript.

Tann San

2009-10-13 12:11

manager   ~0000699

Works for me with the latest release. Can someone test this out and make sure I'm not just born lucky ^_^

administrator

2009-10-13 14:09

administrator   ~0000702

switch to ET or PL to reproduce the error

Tann San

2009-10-13 15:04

manager   ~0000705

I did that before making the last note and it still works for me.

administrator

2009-10-13 15:30

administrator  

bug284.png (15,441 bytes)
bug284.png (15,441 bytes)

Tann San

2009-10-14 09:36

manager   ~0000707

I'm not sure why it would work fine for me on a fresh install on my server but not on your test one. Are you sure that's using the latest SVN build?

administrator

2009-10-14 13:14

administrator   ~0000709

Yes it is the latest SVN build, I wonder if you can use WikiEdit if the 'page language' is set to [pl|et] what causes this on at all on the other installs.

Tann San

2009-10-14 13:35

manager   ~0000710

I just don't seem able to recreate this here. I have my config set to "en" as the main site language. I tried changing it to "de" and running through the steps to recreate the bug and it still works ok for me.

I've totally erased my wiki files and dropped the db tables, another fresh install and it still works for me.

I'm going to unassign this from myself as I can't recreate the problem to see it to fix it.

administrator

2010-10-17 22:30

administrator   ~0000776

WikiEdit loads and works again after a code cleanup (e.g. replaced double quotes with single quotes where possible),

but there is still the "Invalid Range in character class" issue -> see related issue, I close this one as fixed.

Issue History

Date Modified Username Field Change
2009-03-22 15:46 ediworld New Issue
2009-03-22 16:06 administrator Status new => confirmed
2009-03-22 16:06 administrator Product Version => 4.2
2009-03-22 16:06 administrator Relationship added related to 0000238
2009-03-22 16:28 administrator Note Added: 0000610
2009-03-22 16:29 administrator Status confirmed => assigned
2009-03-22 16:29 administrator Assigned To => Tann San
2009-03-22 16:38 administrator Note Edited: 0000610
2009-03-22 16:43 administrator Note Edited: 0000610
2009-09-30 10:55 administrator Target Version => 5.4.0
2009-10-13 12:11 Tann San Note Added: 0000699
2009-10-13 12:11 Tann San Status assigned => feedback
2009-10-13 14:09 administrator Note Added: 0000702
2009-10-13 15:04 Tann San Note Added: 0000705
2009-10-13 15:27 administrator Steps to Reproduce Updated View Revisions
2009-10-13 15:27 administrator Additional Information Updated View Revisions
2009-10-13 15:30 administrator File Added: bug284.png
2009-10-14 09:36 Tann San Note Added: 0000707
2009-10-14 13:14 administrator Note Added: 0000709
2009-10-14 13:35 Tann San Note Added: 0000710
2009-10-14 13:35 Tann San Assigned To Tann San =>
2010-03-08 10:24 administrator Category WikiEdit => wikiedit
2010-10-17 22:30 administrator Note Added: 0000776
2010-10-17 22:30 administrator Status feedback => resolved
2010-10-17 22:30 administrator Resolution open => fixed
2010-10-17 22:30 administrator Fixed in Version => 5.0.beta
2010-10-17 22:30 administrator Target Version 5.4.0 => 5.0.beta
2010-10-17 22:30 administrator Assigned To => administrator
2011-05-31 21:24 administrator Build => R5.0.beta
2015-09-15 17:38 administrator Product Version 4.2 => 4.3.x
2015-09-15 17:38 administrator Summary R43 WikiEdit does not show buttons bar when charset /language is not English/Russian => WikiEdit does not show buttons bar when charset /language is not English/Russian
2015-09-15 18:00 administrator Status resolved => confirmed
2015-09-15 18:00 administrator Resolution fixed => reopened
2015-09-15 18:00 administrator Fixed in Version 5.0.beta =>
2015-09-15 18:00 administrator Target Version 5.0.beta => 6.1.x
2015-09-15 18:00 administrator Summary WikiEdit does not show buttons bar when charset /language is not English/Russian => WikiEdit does not show buttons bar when charset /language is Estonian/Polish
2015-09-15 18:00 administrator Description Updated View Revisions
2015-09-15 18:00 administrator Additional Information Updated View Revisions
2018-08-06 14:37 administrator Target Version 6.1.x => 5.5.7
2019-01-14 14:21 administrator Target Version 5.5.7 => 5.5.8
2019-02-14 12:04 administrator Target Version 5.5.8 => 6.1.x
2019-09-13 09:34 administrator Status confirmed => resolved
2019-09-13 09:34 administrator Resolution reopened => fixed
2019-09-13 09:34 administrator Fixed in Version => 6.0.x
2019-09-13 09:34 administrator Target Version 6.1.x => 6.0.x
2019-10-14 10:33 administrator Fixed in Version 6.0.x => 6.0.beta1