View Issue Details

IDProjectCategoryView StatusLast Update
0000398WackoWikiinstallerpublic2012-03-16 15:42
ReporterAndyM84 Assigned Toadministrator  
PriorityhighSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformMicrosoftOSWindows 
Product Version5.0.rc 
Target Version5.0.0Fixed in Version5.0.rc2 
Summary0000398: Installer Fails Table Creation, Continues Anyway
DescriptionWhile running an install I received green check marks for the database connection and existence tests, but I received a failure message for every other script that was meant to be run.

This behavior happens with both the MySQL and MySQLi libraries. Similar happens with the PDO library, except the page doesn't seem to finish executing.

I am running this on a Rackspace cloud server with Linux as the primary environment.

Let me know if you need any other information, but I am trying to find a solution on my own.
TagsNo tags attached.

Activities

AndyM84

2011-10-01 21:04

updater   ~0000814

A bit more information. They are running MySQL v5.0.77-log on the server. The problem seems to be from the ENGINE={} declarations inside the queries.

AndyM84

2011-10-01 21:13

updater   ~0000815

I'm not sure how this works in earlier/later versions of MySQL, but for this version of MySQL I was able to get this fixed by changing the engine declarations in ~/setup/database-config.php to read as follows:

$engines[] = array('MyISAM', 'myisam', 'MyISAM (recommended)');
$engines[] = array('InnoDB', 'innodb', 'InnoDB');

Before, each were supplying 'mysql_' as the prefix for the second element in the arrays. This made it so the ENGINE={} decl's used 'mysql_myisam' or 'mysql_innodb'. Once I removed the 'mysql_', installation went through without a hitch.

administrator

2011-10-02 07:45

administrator   ~0000818

Had only tested the installer for upgrade and promptly missed the error in the array $engines, f a t a l (error).

I also updated the wacko.r5.0.rc.zip on sf.net. Many thanks.

changeset: http://wackowiki.hg.sourceforge.net/hgweb/wackowiki/stable/rev/357e3ba65fd4

Issue History

Date Modified Username Field Change
2011-10-01 20:53 AndyM84 New Issue
2011-10-01 21:04 AndyM84 Note Added: 0000814
2011-10-01 21:13 AndyM84 Note Added: 0000815
2011-10-01 21:54 administrator Assigned To => administrator
2011-10-01 21:54 administrator Status new => confirmed
2011-10-01 21:54 administrator Target Version => 5.0.0
2011-10-02 07:45 administrator Note Added: 0000818
2011-10-02 07:45 administrator Status confirmed => resolved
2011-10-02 07:45 administrator Resolution open => fixed
2011-10-02 07:45 administrator Fixed in Version => 5.0.0
2012-03-16 15:42 administrator Fixed in Version 5.0.0 => 5.0.rc2