View Issue Details

IDProjectCategoryView StatusLast Update
0000504WackoWikitemplatepublic2018-11-19 14:18
ReporterEvil.2000Assigned Toadministrator 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version5.5.6 
Target Version5.5.7Fixed in Version5.5.7 
Summary0000504: templatest: no main template found in handler/page/template/show.tpl
DescriptionAfter installation on the webhosting provider (unzipping, uploading, db setup and installing via wiki setup) templatest is not able to find any template. Setting any debug or log_level values in $wacko_config does bot show any more output or changes either.

Calling http://<domain>/wiki/admin/ raises an error:

Fatal error: Uncaught Error: Call to undefined method GMP::multiply() in /srv/www/web14/htdocs/wiki/lib/hashids/Hashids.php:391
Stack trace:
#0 /srv/www/web14/htdocs/wiki/lib/hashids/Hashids.php(255): Hashids->unhash('n', 'pw5Qvbkl4JG9OP3...')
#1 /srv/www/web14/htdocs/wiki/class/urirouter.php(251): Hashids->decode('admin')
#2 /srv/www/web14/htdocs/wiki/class/urirouter.php(77): UriRouter->route(Array)
#3 /srv/www/web14/htdocs/wiki/index.php(16): UriRouter->run(Array)
0000004 {main}
  thrown in /srv/www/web134/htdocs/wiki/lib/hashids/Hashids.php on line 391

Calling the default page raises another error:

Fatal error: Uncaught Error: Call to undefined method GMP::greaterThan() in /srv/www/web14/htdocs/wiki/lib/hashids/Hashids.php:256
Stack trace:
#0 /srv/www/web14/htdocs/wiki/class/urirouter.php(251): Hashids->decode('Startseite')
#1 /srv/www/web14/htdocs/wiki/class/urirouter.php(77): UriRouter->route(Array)
#2 /srv/www/web14/htdocs/wiki/index.php(16): UriRouter->run(Array)
#3 {main}
  thrown in /srv/www/web134/htdocs/wiki/lib/hashids/Hashids.php on line 256

I suppose that some includes are not loaded.

Apache error log only spits out notices:
mod_fcgid: stderr: PHP Notice: Uninitialized string offset: 0 in /srv/www/web14/htdocs/wiki/class/templatest.php on line 570
mod_fcgid: stderr: PHP Notice: Uninitialized string offset: 0 in /srv/www/web14/htdocs/wiki/class/templatest.php on line 574
mod_fcgid: stderr: PHP Notice: Uninitialized string offset: 0 in /srv/www/web14/htdocs/wiki/class/templatest.php on line 578
Steps To ReproduceInstall as documented then call the main domain with the wiki folder.
Additional Information$wacko_config = [
    'database_charset' => 'latin1',
    'database_collation' => '0',
    'database_driver' => 'mysqli_legacy',
    'database_engine' => 'MyISAM',
    'database_host' => 'localhost',
    'database_port' => '3306',
    'database_database' => 'web14_wiki',
    'database_user' => 'web14_wiki',
    'database_password' => 'myeyesonly',
    'sql_mode_strict' => '0',
    'table_prefix' => '',
    'system_seed' => 'myeyesonly',
    'recovery_password' => '',
    'hashid_seed' => 'myeyesonly',
    'wacko_version' => '5.5.6',
    'cache' => 0,
    'debug' => 1,
    'log_level' => 7,
];
TagsNo tags attached.

Relationships

related to 0000505 resolvedadministrator Wacko crashes with installed php-gmp 

Activities

administrator

2018-11-15 08:27

administrator   ~0001011

Last edited: 2018-11-15 08:52

View 6 revisions

Looks like a dependency issue of the hashid lib regarding GMP. I need to reproduce the error before I can say more.

Hashids requires either the BC Math or GMP extension in order to work. Please check if at least one of the extension is available.
https://github.com/ivanakimov/hashids.php/blob/master/README.md

Perhaps there is a namespace issue?

administrator

2018-11-19 14:18

administrator   ~0001021

Issue were fixed, see 0000505

Issue History

Date Modified Username Field Change
2018-11-01 13:24 Evil.2000 New Issue
2018-11-15 08:27 administrator Assigned To => administrator
2018-11-15 08:27 administrator Status new => assigned
2018-11-15 08:27 administrator Note Added: 0001011
2018-11-15 08:27 administrator Note Edited: 0001011 View Revisions
2018-11-15 08:43 administrator Note Edited: 0001011 View Revisions
2018-11-15 08:44 administrator Note Edited: 0001011 View Revisions
2018-11-15 08:50 administrator Note Edited: 0001011 View Revisions
2018-11-15 08:52 administrator Note Edited: 0001011 View Revisions
2018-11-15 08:53 administrator Status assigned => feedback
2018-11-15 15:04 administrator Relationship added related to 0000505
2018-11-19 14:18 administrator Status feedback => resolved
2018-11-19 14:18 administrator Resolution open => duplicate
2018-11-19 14:18 administrator Fixed in Version => 5.5.7
2018-11-19 14:18 administrator Target Version => 5.5.7
2018-11-19 14:18 administrator Note Added: 0001021