View Issue Details

IDProjectCategoryView StatusLast Update
0000548WackoWikiactionpublic2019-11-03 11:21
Reporteradministrator Assigned Toadministrator  
PrioritynormalSeveritytweakReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version5.4.0 
Target Version5.5.15Fixed in Version5.5.15 
Summary0000548: redirect: change the default HTTP status code to 301
Description{{redirect to="NewPage" [temporary=1]}}

temporary =1 sets HTTP status code to 302 (default: 301)
Additional InformationRedirect action should generate HTTP status code 301 by default to let the user delete the old page after the new one is properly indexed by search engines.
302 redirect is only a temporary one according to RFC7231 https://tools.ietf.org/html/rfc7231#section-6.4.3 :

6.4.3. 302 Found

   The 302 (Found) status code indicates that the target resource
   resides temporarily under a different URI. Since the redirection
   might be altered on occasion, the client ought to continue to use the
   effective request URI for future requests.

So to clean our search engine site index of crappy old pages URLs and to let Redirect action call be shorter it's better to make it 301 by default and add temporary=1 to set HTTP status code to 302.
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2019-11-03 10:51 administrator New Issue
2019-11-03 10:51 administrator Status new => assigned
2019-11-03 10:51 administrator Assigned To => administrator
2019-11-03 10:52 administrator Status assigned => resolved
2019-11-03 10:52 administrator Resolution open => fixed
2019-11-03 10:52 administrator Fixed in Version => 5.5.15
2019-11-03 10:52 administrator Note Added: 0001073
2019-11-03 10:53 administrator Summary redirect: set default HTTP status code to 301 => redirect: change the default HTTP status code to 301
2019-11-03 11:21 administrator Additional Information Updated View Revisions