New installation, /Login results in 404 not found

I have my installation here

Going to this URL results in 404 Not Found.

I'm using Apache httpd under RHEL 8.


  1. Re: New installation, /Login results in 404 not found

    see /Doc/English/ModRewrite

    You have somewhere a Apache configuration issue, rewrite_mode should only affect the wiki folder (per-directory context, .htaccess file).

    Variant A (preferred)
    • rewrite_mode on (Apache)
    • AllowOverride All
    • .htaccess in wiki root folder (directory context)
      • Setting rules in .htaccess is convenient, especially with multiple websites on the same server. It does not require a server restart for changes to take effect and it does not require root privileges to edit those rules, simplifying maintenance and making changes possible with an unprivileged account.

    Variant B
    • rewrite_mode on (Apache)
    • httpd.conf / apache2.conf
      • Any rules that you can put in an .htaccess file can be also put directly into server configuration files. In fact, the official Apache documentation recommends using server configuration files instead of .htaccess because Apache processes it faster that way.
    • remove or rename .htaccess in wiki root folder

    Variant C
    • rewrite_mode off (Apache)

    Variant D (only for debugging)
    • const AUTO_REWRITE = 0; (in config/constants.php)
    • rename .htaccess in wiki root folder, e.g. dist.htaccess
    • This way you disable the rewrite_mode of WackoWiki even LoadModule rewrite_module modules/ is activated.

    // if .htaccess tell us actual info on mod_rewrite status - use it
    if (getenv('HTTP_MOD_ENV') === 'on' && AUTO_REWRITE)
        $this->rewrite_mode = (getenv('HTTP_MOD_REWRITE') === 'on');
    • WikiAdmin
    • 26.04.2024 11:01 edited
  2. Re: New installation, /Login results in 404 not found

    I went directly to option D here, and updated constants.php with

    const AUTO_REWRITE = 0; (it was previously 1)

    All links in the wiki are still shown with fancy URLs and not traditional ?var=value&var2=value2

    I've tried deleting all files from the _cache folder – same result

    I tried copying the updated config.php and constants.php to the _cache/constants/ folder – same result

    I've accessed the wiki with a different browser to rule out weird localized caching – same result
  3. Re: New installation, /Login results in 404 not found

    There are two ends, Apache and the WackoWiki engine. You have to activate or deactivate both.

    If you want activate mode_rewrite you have to ensure that the .htaccess file is taken into account.
    Otherwise you have to delete or rename the .htaccess file.
Log in or create an account to post a comment.