View Issue Details

IDProjectCategoryView StatusLast Update
0000180WackoWikiinstallerpublic2017-08-31 09:36
ReporterTheBoneAssigned Toadministrator 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target Version5.5.0Fixed in Version5.5.0 
Summary0000180: URL rewrite did not work on subdomain with current .htaccess
DescriptionTested on domainfactory hosting. PHP4 and PHP5.
Subdomain wacko.yourhp.de
After upload of the alpha3 and SVN release a 500 Server Error occur after try to start index.php

After deletion of the .htaccess file in the root everthing works fine again.
TagsNo tags attached.

Relationships

related to 0000397 resolvedadministrator Problem with .htaccess on Rackspace Cloud Server 
related to 0000297 resolvedadministrator Switching Domain not possible? 
related to 0000443 resolvedbirnbacs Rewriting causes Admin Panel to be non accessible 

Activities

administrator

2008-06-14 01:27

administrator   ~0000367

Last edited: 2009-01-06 17:07

http://wackowiki.org/Doc/Deutsch/RewriteModus

Auch nach langer Suche habe ich keinen Grund gefunden, aber die o.g. Rewrite funktioniert bei externer Linkd(f nicht. Wer trotzdem auf schöne URLs nicht verzichten möchte, der muss seine .htaccess mit folgendem Inhalt füllen:

RewriteEngine on RewriteRule ^$ /wakka.php [L]
RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule (.*) /wakka.php?wakka=$1 [QSA,L]
RewriteRule ^index.php$ /wakka.php

Der Rest bleibt identisch. TheBone /07.05.2006 02:13/

TheBone

2008-06-14 20:59

developer   ~0000368

Oh, I wrote that? Seems that the problem is not new.
But with a new release it should be solved by default or somehow done by the installer. Maybe the rewirte mod should not be the default prior the installation.

Let the installer write the .htaccess file depending on the hoster.

Tann San

2008-06-16 14:50

manager   ~0000370

The htaccess file is copied to the server by the admin along with all the other files including the installer. They then run the installer in the setup directory. That doesn't actually copy any files to the server since the admin has already done that.

The installer "could" delete the htaccess file if it was given the correct permissions by the admin (in case the chmod system doesn't work on that server). It's easier to just get the admin to delete the file themselves.

A better solution would be to modify the htaccess file so it doesn't cause a problem but without more information I don't know what to do. I have it running in a sub domain, the parent has it's own htaccess file. No problems here.

Tann San

2008-06-16 14:51

manager   ~0000371

...saying all that though; maybe you should take care of it since you originally wrote that part of the system :¬)

mir

2008-09-03 18:40

developer   ~0000486

Last edited: 2008-09-03 18:40

Hi all,

May I suggest the following to solve this issue?

The installer should add the following conf file to /etc/apache2/conf.d/

# wacko.conf
<Directory /var/www/wacko>
    Options FollowSymLinks
    AllowOverride AuthConfig Limit FileInfo Options
    Order allow,deny
    Allow from all
</Directory>

Off course the directory setting needs to apply to the actual top folder for wacko.

A side effect, if the installer is the one to create the file, is that the installer needs to be run as root or have write access to /etc/apache2/conf.d/
so maybe the best way would be to instruct users to copy it manually.

Another option could be to simply ignore if mod_rewrite is installed and leave this as an advanced option?

TheBone

2008-09-03 19:08

developer   ~0000487

add the following conf file to /etc/apache2/conf.d/

That won't work. You will never get access to that file on any shared server hoster. Only if you have a root server and that is a minority of web server.

mir

2008-09-03 19:21

developer   ~0000488

"That won't work. You will never get access to that file on any shared server hoster"

The same thing applies to activating mod_rewrite in an .htaccess file, it requres permissions from a person with admin access rights.

That is why I in the last paragraf suggest this feature to be an advanced option and instruct the installer to disregard if mod_rewrite is available.

mir

2008-09-03 19:28

developer   ~0000489

Doing some further testing. It actually seems appropriate to leave it to:
AllowOverwrite FileInfo

TheBone

2008-09-03 21:39

developer   ~0000490

Can you please rename your current htaccess file to something.
create a php file in the Wakko install folder and copy this code into:
<?php
$Datei = ".htaccess";
$current_folder = dirname($_SERVER['PHP_SELF']);
$Text = "RewriteEngine on
RewriteBase ".$current_folder."/
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.*/[^\./]*[^/])$ $1/
RewriteRule ^(robots\.txt)$ robots.txt [L]
RewriteRule ^(sitemap\.xml)$ sitemap.xml [L]
RewriteRule ^(favicon\.ico)$ favicon.ico [L]
RewriteRule ^(.*)$ index.php?page=$1 [QSA,L]
";

$erstellen = fopen($Datei, "w");
if(fwrite($erstellen, $Text)){echo ".htaccess created!";}
fclose($erstellen);
?>

execute that php file and check if your wakko installation runs.

administrator

2015-03-08 19:12

administrator   ~0000940

see 0000443

Issue History

Date Modified Username Field Change
2008-06-11 11:58 TheBone New Issue
2008-06-11 11:58 TheBone Legacy => NEW
2008-06-14 01:27 administrator Note Added: 0000367
2008-06-14 20:59 TheBone Note Added: 0000368
2008-06-16 14:50 Tann San Note Added: 0000370
2008-06-16 14:51 Tann San Note Added: 0000371
2008-08-01 23:23 administrator Status new => acknowledged
2008-08-23 14:03 administrator Note Edited: 0000367
2008-08-27 00:59 administrator Category Installation => Installer
2008-09-03 18:40 mir Note Added: 0000486
2008-09-03 18:40 mir Note Edited: 0000486
2008-09-03 19:08 TheBone Note Added: 0000487
2008-09-03 19:21 mir Note Added: 0000488
2008-09-03 19:28 mir Note Added: 0000489
2008-09-03 21:39 TheBone Note Added: 0000490
2009-01-06 17:07 administrator Note Edited: 0000367
2009-08-13 15:08 administrator Target Version => 5.4.0
2009-10-11 18:26 administrator Assigned To => TheBone
2009-10-11 19:00 administrator Relationship added related to 0000297
2010-03-08 10:14 administrator Category Installer => installer
2010-08-07 17:08 administrator Assigned To TheBone => administrator
2010-08-07 17:08 administrator Status acknowledged => assigned
2010-08-07 17:08 administrator Target Version 5.4.0 => 5.0.0
2012-02-02 17:03 administrator Relationship added related to 0000397
2012-03-09 15:40 administrator Severity crash => tweak
2012-04-22 17:04 administrator Target Version 5.0.0 => 5.4.0
2014-03-21 14:57 administrator Target Version 5.4.0 => 5.5.0
2014-07-13 06:43 administrator Relationship added related to 0000443
2015-03-08 19:12 administrator Note Added: 0000940
2015-03-08 19:12 administrator Status assigned => resolved
2015-03-08 19:12 administrator Resolution open => duplicate
2015-03-08 19:12 administrator Fixed in Version => 5.5.0
2016-09-21 09:18 administrator Fixed in Version 5.5.0 => 5.5.rc2
2017-08-31 09:36 administrator Fixed in Version 5.5.rc2 => 5.5.0