View Issue Details

IDProjectCategoryView StatusLast Update
0000024WackoWikieditingpublic2009-10-13 16:05
Reporteradministrator Assigned Toadministrator  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.2 
Target Version5.0.betaFixed in Version5.0.beta 
Summary0000024: add change summary / comments
DescriptionThis feature is seen in many wikis. When you edit a page you can add an optional comment as to what you changed. This comment is then displayed in the recient changes and page history.

add field to table pages and revisions [done]
edit_note VARCHAR(100) NOT NULL DEFAULT '',
Steps To Reproducemake it optional (to keep the GUI uncluttered)
Settings:
config
-> change_summary on/off (gui + feature)
-> change_summarydefault on/off
user otion (?)
-> edit_note on/off

More:
http://wackowiki.org/Dev/NewFeatures/ChangeSummary
Additional Informationedit_note VARCHAR(100) NOT NULL DEFAULT '',
TagsNo tags attached.

Relationships

related to 0000046 resolvedadministrator Add "minor edit" option to edit window 

Activities

EoNy

2007-08-28 00:40

manager   ~0000021

To be clear this is different from the comment thread on individual pages. This is part of the change history.
 
kukutz
05-08-2004 15:14

    This feature in fact already here, but isn't on surface =)

In page settings there's description.

I think, this field will be description of "commit".

Will think, though.
 
tomspilman
11-02-2005 11:26

    Anything new on this feature request? It would help *alot* especially on the RSS feed for the recent changes.
 
urbansheep
17-02-2005 23:54

    How does "description" in the page's settings reflect the comment to the changes? And how's it supposed to work?

Tann San

2007-09-23 00:00

manager   ~0000101

It doesn't. The description field is used in the description meta tag generated in the head section of each page. kukutz was wrong in its usage.

administrator

2009-07-02 16:59

administrator   ~0000662

ebal 2008-08-31 11:27

I would like every time i re-edit a page to add a small text entry for the reason. It is very useful (to me at least) after a loooong time to see why i re-edit a page. I use recent-changes and simple diff for this now, but i thought it would be even more nicer to simple read the reason at recent pages without diff 10-20 pages or what so ever.

Perhaps when someone create a new page, the text entry should write: new page
and all other times just the reason for re-editing.

I was thinking a new table at db for this.

administrator

2009-07-04 15:54

administrator   ~0000664

Last edited: 2009-07-04 21:28

View 2 revisions

update rev494 - added initial support for edit summary

basic implementation done -> you can try it out in our test wiki

Issue History

Date Modified Username Field Change
2007-08-28 00:40 EoNy New Issue
2007-08-28 00:40 EoNy Note Added: 0000021
2007-08-29 05:58 administrator Legacy => NPJ
2007-08-31 00:29 administrator Status new => acknowledged
2007-08-31 00:29 administrator Target Version => 5.0.0
2007-09-23 00:00 Tann San Note Added: 0000101
2007-12-12 23:36 administrator Target Version 5.0.0 => 7.0.x
2008-08-31 13:10 administrator Summary Change comments => Change comments / summary
2008-08-31 13:12 administrator Relationship added related to 0000046
2009-07-02 10:10 administrator Reporter EoNy => administrator
2009-07-02 10:10 administrator Assigned To => administrator
2009-07-02 10:10 administrator Status acknowledged => assigned
2009-07-02 10:10 administrator Target Version 7.0.x => 5.0.0
2009-07-02 10:10 administrator Steps to Reproduce Updated View Revisions
2009-07-02 10:24 administrator Steps to Reproduce Updated View Revisions
2009-07-02 16:59 administrator Note Added: 0000662
2009-07-02 17:02 administrator Description Updated View Revisions
2009-07-02 17:02 administrator Additional Information Updated View Revisions
2009-07-04 15:54 administrator Note Added: 0000664
2009-07-04 21:28 administrator Note Edited: 0000664 View Revisions
2009-07-06 16:43 administrator Status assigned => resolved
2009-07-06 16:43 administrator Resolution open => fixed
2009-07-06 16:43 administrator Fixed in Version => 5.0.0
2009-07-06 16:44 administrator Summary Change comments / summary => add change comments / summary
2009-07-07 10:03 administrator Summary add change comments / summary => add change summary / comments
2009-10-13 15:58 administrator Target Version 5.0.0 => 5.0.beta
2009-10-13 16:05 administrator Fixed in Version 5.0.0 => 5.0.beta
2010-02-22 18:18 Freeman Relationship added child of 0000352
2010-02-22 18:22 Freeman Relationship deleted child of 0000352
2010-03-08 10:12 administrator Category Editing => editing