View Issue Details

IDProjectCategoryView StatusLast Update
0000369WackoWikicachepublic2017-02-10 15:21
ReporterElar9000 
Assigned ToRideSnowNow 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.rc 
Target Version5.5.xFixed in Version5.5.rc2 
Summary0000369: Improve caching system to pass more of Google Page Speed tests
DescriptionWhat Page Speed is - http://googlecode.blogspot.com/2009/06/introducing-page-speed.html (like Yahoo's YSlow but with some significant extras).

What we need to do on caching:
1. Store html cache gzipped and send it to client with proper header
2. Store css and js in cache gzipped and send it to client with proper header
3. Store xml gzipped and send it to client with proper header

What else:
1. We got many css and js - we should make a procedure to combine all css to a single compressed css file, and all js to a single compressed js file and send to client single preprocessed js file and css file and already gzipped.
2. I mean compressed is not only gzipped, but removed \r\n and spaces, shortened vars etc. See google for "compress javascript", "compress css" for details.
3. We should send browser caching headers for some images, css and js.

This won't take us much resources because all the processing is made once and then we give the stuff from cache.
Steps To ReproduceHope you all got Firefox:
1. Install Firebug for your Firefox.
2. Install Page Speed for your Firebug.
3. Check what Page Speed says about http://wackowiki.org/ :
  a) Open URL,
  b) Press F12,
  c) Open Page Speed tab in Firebug.
TagsNo tags attached.

Relationships

Activities

administrator

2010-08-07 13:51

administrator   ~0000769

Last edited: 2017-02-10 15:21

View 1 revisions

better you test with our recent version with sql cache https://wackowiki.org/lab/

the downside of compressed css and JS might be the client caching

Issue History

Date Modified Username Field Change
2010-06-26 10:28 Elar9000 New Issue
2010-08-07 13:51 administrator Note Added: 0000769
2012-04-22 17:04 administrator Target Version 5.0.0 => 5.4.0
2014-03-21 14:57 administrator Target Version 5.4.0 => 5.5.x
2015-02-19 19:29 administrator Target Version 5.5.x => 5.6.x
2017-02-10 15:20 administrator Assigned To => RideSnowNow
2017-02-10 15:20 administrator Status new => resolved
2017-02-10 15:20 administrator Resolution open => fixed
2017-02-10 15:20 administrator Fixed in Version => 5.5.rc2
2017-02-10 15:20 administrator Target Version 5.6.x => 5.5.x
2017-02-10 15:20 administrator Summary Should make caching system better to pass more of Google Page Speed tests => Improve caching system to pass more of Google Page Speed tests
2017-02-10 15:21 administrator Note Edited: 0000769 View Revisions
2017-02-19 13:23 administrator Note Revision Dropped: 769: 0000739