View Issue Details

IDProjectCategoryView StatusLast Update
0000519WackoWikiadministrationpublic2019-08-22 11:03
Reporterascrnet Assigned Toadministrator  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version10
Product Version5.5.12 
Target Version5.5.13Fixed in Version5.5.13 
Summary0000519: Username with upper and lower case letters
DescriptionThe user "AsCrNet" was created from the administration menu (see image user01), then you see the user already created and with the normal name (see image user02). but in the wiki you see with spaces "As Cr Net" see image user03). Checking the database, the information was saved with blank spaces (see image user04)
TagsNo tags attached.

Activities

ascrnet

2019-08-17 01:23

reporter  

user01.png (13,837 bytes)
user01.png (13,837 bytes)
user02.png (2,672 bytes)
user02.png (2,672 bytes)
user04.png (34,237 bytes)
user04.png (34,237 bytes)
user03.png (12,411 bytes)
user03.png (12,411 bytes)

administrator

2019-08-22 11:03

administrator   ~0001044

It was caused be the get_page_title() function because no title was provided. There are more related issues, in the one hand its a legacy function on the other a feature to add spaces to WikiWords.

Thanks for reporting.

https://bitbucket.org/wackowiki/wackowiki-dev/commits/19a569c7612a7ebe356c17f746e19b86ef6587ea (5.5)
https://bitbucket.org/wackowiki/wackowiki-dev/commits/b232cd59ccd7f0594273fd3cb1b459700d9a087d (default)

Issue History

Date Modified Username Field Change
2019-08-17 01:23 ascrnet New Issue
2019-08-17 01:23 ascrnet File Added: user01.png
2019-08-17 01:23 ascrnet File Added: user02.png
2019-08-17 01:23 ascrnet File Added: user04.png
2019-08-17 01:23 ascrnet File Added: user03.png
2019-08-22 11:03 administrator Assigned To => administrator
2019-08-22 11:03 administrator Status new => resolved
2019-08-22 11:03 administrator Resolution open => fixed
2019-08-22 11:03 administrator Fixed in Version => 5.5.13
2019-08-22 11:03 administrator Target Version => 5.5.13
2019-08-22 11:03 administrator Note Added: 0001044