View Issue Details

IDProjectCategoryView StatusLast Update
0000059WackoWikicachepublic2009-10-13 16:03
ReporterEoNy Assigned Toadministrator  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionopen 
Product Version4.2 
Target Version5.0.betaFixed in Version5.0.beta 
Summary0000059: Bad links in header after language in user profile changed to polish.
DescriptionI registered and in settings changed language to polish.

Header becomes to this:
Home Page | Index Stron | Ostatnie Zmiany? | Ostatnio Komentowane? | U┼╝ytkownicy | Rejestracja? | + | Piotr Gryko ( Ustawienia | Wyloguj )

(only "Home Page", "Piotr Gryko", "Ustawienia", "Wyloguj" links works)

Next - I changed to English and nothing change.

Steps To Reproducethe incorrect lang.pl.php causes all this -> fix lang.pl.php
http://wackowiki.org/Dev/Translations/pl
Additional InformationMeaning:
Index Stron -> Page Index
Ostatnie Zmiany -> Last Changes
Ostatnio Komentowane -> Last Comments
U┼╝ytkownicy -> Users
Rejestracja -> Registrations
Ustawienia -> Settings
Wyloguj -> Logout
TagsNo tags attached.

Relationships

related to 0000020 resolvedadministrator SingleLanguage - Polish -> impossible to login/logout 
related to 0000099 resolvedTann San Ukrainian language for formatter typografica 
parent of 0000130 resolvedadministrator Always return iso-8859-1 
parent of 0000010 resolvedadministrator language-independent interface 
related to 0000238 resolvedadministrator lang.et.php or lang.pl.php-> "Invalid Range in character class". -> JavaScript. 

Activities

Freeman

2008-07-27 18:40

developer   ~0000440

Last edited: 2008-08-23 14:50

WackoWiki.org returns iso-8859-1 two times as described at 0000130 (before and after <title>), but lang.pl.php sets iso-8859-2 for Polish.

Freeman

2008-08-03 14:56

developer   ~0000459

Last edited: 2008-08-23 13:56

Unfortunately, now I have no time to install WackoWiki locally and test it in depth. These issues got from http://test.wackowiki.org. Some ideas here are related to 0000130, but I wrote them below. :)

The main issue is: Polish still isn't working.

Yes, now WackoWiki somewhere returns iso-8859-2, and do it once, but some pages is already invalid. Heading links described above, are not links (just bold text) and look invalid: I choose Polish during registration, but these links created at Russian. Through iso-8859-2 chicken-feed differs, but keep chicken-feed yet. :)

administrator

2008-08-10 14:34

administrator   ~0000467

guess this will be the same case with Czech (iso-8859-2)

administrator

2008-09-08 16:06

administrator   ~0000502

Last edited: 2008-10-13 19:28

invalid range in character class
Polish links will work only with browser local pl_PL (ISO-8859-2)

the incorrect lang.pl.php causes all this, I will try to fix the lang.pl.php file for R4.3 but it's uncertain if this will fix the whole issue ...

Freeman

2008-10-14 16:51

developer   ~0000524

I think that corrected version uploaded on WackoWiki.org because some pages will corrupt, like http://wackowiki.org/Dev/Roadmap/diff?a=-1&b=1868 when inteface switched to Polish.

administrator

2008-10-14 17:15

administrator   ~0000525

Last edited: 2008-10-14 20:50

Yep, wow what was that?

I uploaded ISO 8859-2 chars encoded as ISO 8859-1 to the site - I'm a hero :)

administrator

2008-10-14 20:51

administrator   ~0000526

Fix SVNed with revision 176

Issue History

Date Modified Username Field Change
2007-08-31 16:12 EoNy New Issue
2007-08-31 16:12 EoNy Legacy => NEW
2007-08-31 21:02 administrator Legacy NEW => NPJ
2008-05-16 02:39 administrator Relationship added related to 0000020
2008-07-27 18:30 Freeman Relationship added parent of 0000130
2008-07-27 18:40 Freeman Note Added: 0000440
2008-07-27 19:32 Freeman Note Edited: 0000440
2008-08-03 14:56 Freeman Note Added: 0000459
2008-08-04 10:57 administrator Relationship added related to 0000099
2008-08-04 11:00 administrator Relationship added parent of 0000010
2008-08-10 14:34 administrator Note Added: 0000467
2008-08-23 13:56 administrator Note Edited: 0000459
2008-08-23 14:50 administrator Note Edited: 0000440
2008-09-08 16:06 administrator Note Added: 0000502
2008-09-08 19:07 administrator Status new => acknowledged
2008-09-16 23:51 administrator Note Edited: 0000502
2008-09-30 15:25 administrator Description Updated
2008-09-30 15:25 administrator Additional Information Updated
2008-09-30 15:57 administrator Description Updated
2008-10-01 18:15 administrator Steps to Reproduce Updated
2008-10-07 19:25 administrator Note Edited: 0000502
2008-10-07 19:35 administrator Note Edited: 0000502
2008-10-13 19:26 administrator Target Version => 5.0.0
2008-10-13 19:28 administrator Note Edited: 0000502
2008-10-13 19:32 administrator Description Updated
2008-10-13 19:32 administrator Steps to Reproduce Updated
2008-10-14 16:51 Freeman Note Added: 0000524
2008-10-14 17:15 administrator Note Added: 0000525
2008-10-14 17:39 administrator Note Edited: 0000525
2008-10-14 20:47 administrator Assigned To => administrator
2008-10-14 20:47 administrator Status acknowledged => resolved
2008-10-14 20:47 administrator Fixed in Version => 5.0.0
2008-10-14 20:47 administrator Description Updated
2008-10-14 20:50 administrator Note Edited: 0000525
2008-10-14 20:51 administrator Note Added: 0000526
2008-10-14 20:52 administrator Relationship added related to 0000238
2009-10-13 16:00 administrator Target Version 5.0.0 => 5.0.beta
2009-10-13 16:03 administrator Fixed in Version 5.0.0 => 5.0.beta
2010-03-08 10:11 administrator Category Cache => cache