View Issue Details

IDProjectCategoryView StatusLast Update
0000089WackoWikihandlerpublic2009-10-13 15:58
ReporterTann SanAssigned ToTann San 
PriorityhighSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2 
Target Version5.0.betaFixed in Version4.3.rc 
Summary0000089: Redirect non logged in users to the language that suits their system as default
Descriptionautomatically adjust the user interface to browsers preferred language and display localized contents

for visitors or users not logged in yet, we should take the browser
$HTTP_ACCEPT_LANGUAGE and override then the $wakkaConfig "language" =>
"xy", else (no such language available) standard language, or EN (if there)

the example above redirects to an defined page
TagsNo tags attached.

Relationships

related to 0000010 new language-independent interface 
parent of 0000334 resolvedadministrator bookmarks shown for other language if multilanguage is off 
related to 0000320 resolvedadministrator page cache should also depend on language 
child of 0000159 resolvedadministrator Localize RSS messages 
child of 0000221 resolvedadministrator cache issue & browser default language settings from guest 

Activities

Tann San

2007-09-26 09:28

manager   ~0000111

Last edited: 2009-01-06 17:06

http://wackowiki.org/Doc/Deutsch/Probleme/WackoIdeen/DifferentHomepage

this is Andys hack he has done for his school in Muerten

Tann San

2008-06-30 14:42

manager   ~0000392

If the user is logged in then it will use their configured language. If they have none set or are not logged in then it will check the HTTP_ACCEPT_LANGUAGE value and use that if the relevant language files are available. Failing that it defaults to the config option set by the admin during installation. Tested in FF3 via the Tools->Options->Content->Languages->Choose panel.

administrator

2008-07-03 14:41

administrator   ~0000406

added auto detection also for bookmarks

the cache function still takes the last written version and do not differentiate between the given languages

DidierSpaier

2009-05-10 21:12

developer   ~0000651

Last edited: 2009-05-10 21:14

If I un-check Multingual at installation time, then a problem arise if browser's preferred language differ from language chosen during the installation. Then (e.g. for browser's preferred language=>en whilst wacko config language=>fr) some standard bookmarks don't work, because corresponding pages were not inserted in the database. So we see Changes?, Index? and Comments? instead of working links because RecentChanges, PageIndex and RecentlyCommented tagged pages were not inserted in the database during installation (see appended snapshot wackowiki4.png).

As a workaround I suggest that if "multilinguage" is not set to "on" or is not present in the configuration file, GUI language be always set to the one indicated in the "language" parameter of the same file, not considering browser's setting at all in this case.

administrator

2009-07-15 10:41

administrator   ~0000667

Last edited: 2009-10-11 12:52

View 3 revisions

added for your issue a new ticket -> 0000334

Issue History

Date Modified Username Field Change
2007-09-25 09:20 Tann San New Issue
2007-09-25 09:20 Tann San Legacy => NEW
2007-09-26 09:28 Tann San Note Added: 0000111
2007-11-02 07:58 administrator Priority normal => high
2007-11-02 07:58 administrator Target Version => 5.0.0
2007-11-02 08:00 administrator Status new => confirmed
2007-11-30 21:57 administrator Relationship added related to 0000010
2008-04-04 01:23 administrator Relationship added child of 0000159
2008-04-10 18:37 administrator Description Updated
2008-04-10 18:38 administrator Description Updated
2008-04-10 18:39 administrator Note Edited: 0000111
2008-05-11 14:10 administrator Note Edited: 0000111
2008-05-11 14:12 administrator Description Updated
2008-06-30 14:42 Tann San Note Added: 0000392
2008-06-30 14:42 Tann San Status confirmed => resolved
2008-06-30 14:42 Tann San Fixed in Version => 5.0.0
2008-06-30 14:42 Tann San Resolution open => fixed
2008-06-30 14:42 Tann San Assigned To => Tann San
2008-07-03 14:41 administrator Note Added: 0000406
2008-08-23 13:47 administrator Note Edited: 0000111
2008-08-23 14:18 administrator Description Updated
2008-08-24 01:27 administrator Description Updated
2008-08-24 01:56 administrator Relationship added child of 0000221
2009-01-06 17:05 administrator Description Updated
2009-01-06 17:06 administrator Note Edited: 0000111
2009-05-10 21:12 DidierSpaier Note Added: 0000651
2009-05-10 21:12 DidierSpaier Status resolved => feedback
2009-05-10 21:12 DidierSpaier Resolution fixed => reopened
2009-05-10 21:14 DidierSpaier File Added: wackowiki4.png
2009-05-10 21:14 DidierSpaier Note Edited: 0000651
2009-07-15 10:38 administrator Fixed in Version 5.0.0 =>
2009-07-15 10:41 administrator Note Added: 0000667
2009-07-15 10:41 administrator Resolution reopened => open
2009-08-22 11:02 administrator Relationship added related to 0000320
2009-10-11 12:44 administrator Status feedback => resolved
2009-10-11 12:44 administrator Resolution open => fixed
2009-10-11 12:44 administrator Fixed in Version => 4.3.rc
2009-10-11 12:44 administrator Description Updated View Revisions
2009-10-11 12:49 administrator Issue cloned: 0000334
2009-10-11 12:49 administrator Relationship added parent of 0000334
2009-10-11 12:51 administrator File Deleted: wackowiki4.png
2009-10-11 12:52 administrator Note Edited: 0000667 View Revisions
2009-10-11 12:52 administrator Note Edited: 0000667 View Revisions
2009-10-13 15:58 administrator Target Version 5.0.0 => 5.0.beta
2010-03-08 10:14 administrator Category Handler => handler