Session File Store: inaccessible directory "/tmp"

Installed wacko, all successful until finally got error message:
SessionFileStore: inaccessible directory "/tmp" and blocked ("rien ne va plus")

- manually make new directory tmp + releasing rights
- opened config.php and looks fine

- 'wacko_version' => '5.5.8',
- locally, on xampp windows ApacheFriends XAMPP Version 7.2.4

What did I do wrong? Tnx in advance!


  1. Re: inaccessible directory "/tmp"

    Your XAMPP has either insufficient user or access rights for the '/tmp' folder or the folder resides in a different location..

    Possible options:

    Change in constants.php the value for CACHE_SESSION_DIR to _cache/session or in your case /xampp/tmp
    const CACHE_SESSION_DIR		= '/tmp';	// '_cache/session'	

    tmp folder for XAMPP Windows

    The default tmp/ folder for XAMPP Windows resides under C:\xampp\tmp, see Session handling.

    const CACHE_SESSION_DIR = '/xampp/tmp';

    Change in the secondary config / Admin panel System section the session_store value for Session handling from File (1) to Database (2).

    Address your insufficient user or access rights for the '/tmp' folder. On Windows you might want chose option A or B.

    • WikiAdmin
    • 01.11.2023 18:16 edited
  2. A not working; C done; B= ??

    Tnx for suggestions:
    option A: done, but returned "SessionFileStore: inaccessible directory "/_cache/session""
    option C: done, all Windows permissions set to "allow" etc
    option B: cannot find file to edit, where exactly is it?

    Tnx again, ciao
  3. Re: session_store settings

    To A, same issue like C, set the necessary access rights for the folder /_cache/session and user (xampp).

    To B, you can change the value session_store either in the config table or via the Admin panel in the System section.

    AP change session store modi
    Change the session store modi from File to Database.

    • WikiAdmin
    • 25.08.2020 07:42 edited
Log in or create an account to post a comment.