Suddenly a new problem

I forgot to copy what I had typed before I pressed save. /)_-

Reader's Digest version:
I stepped away to have a nap shortly after I got Wacko installed.
Now I can't log in. I get a "The connection has timed out" message.
I've been trying for the last 3 hours to figure out how to fix it.
I could not find any settings to set the page load timeout.
I don't know how the "Recovery Password" works if you can't log in as admin to set it in the first place.


0586123a8d9171e6f538fede748a10ea.png 11.0 KiB  08.01.2022 18:00 
2d48b15786cd6e8bbb15c33867880e79.png 12.5 KiB  08.01.2022 18:00 
2db5bcdffd16dcb1965e6c44a6c1b597.png 24.6 KiB  08.01.2022 17:59 
2f98839b02f45bb9aa42b1295b3a76d9.png 18.9 KiB  08.01.2022 17:59 
49439b55512ed72e852e0980fda89a4a.png 11.0 KiB  08.01.2022 18:00 
4ffc1ce888cc518d311e7897182fb42c.png 7.8 KiB  08.01.2022 18:01 
a892345a0322b75d92097dc14853bd86.png 13.8 KiB  08.01.2022 17:59 
b34c605f001e1dc00aaa27b826dbcbc1.png 25.2 KiB  08.01.2022 18:00 
d603a36040eee529ed6a78dace89897b.png 28.7 KiB  08.01.2022 17:59 


  1. Re: Suddenly A New Problem


    Apache and MySQL are both running.

    Starting on localhost/wiki and click on "Login" - - [08/Jan/2021:22:24:17 -0500] "GET /wiki/theme/default/icon/print.svg HTTP/1.1" 200 410 "http://localhost/wiki/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0" - - [08/Jan/2021:22:24:18 -0500] "GET / HTTP/1.1" 302 - "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0" - - [08/Jan/2021:22:24:18 -0500] "GET /dashboard/ HTTP/1.1" 200 7577 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0" - - [08/Jan/2021:22:24:15 -0500] "GET /wiki/Login HTTP/1.1" 200 1874 "http://localhost/wiki/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0"	

     libpng warning: iCCP: known incorrect sRGB profile	

    owever, this was posted before my most recent attempt. There is no time stamp, but it happened between 12:00 pm and 10:15 pm Eastern

    I don't even remember if I had logged in to the default admin account before this happened. It's been hours.
    • Breantique
    • 08.01.2022 18:03 edited
  2. Re: Suddenly A New Problem

    Please try to shutdown and restart Apache and MySQL. I'm not familiar with your OS environment, but there are some usual causes for this. You can put xampp the connection has timed out in your favorite search engine to get some ideas what it might be in your case.

    Could be your firewall, a security suite, another application took a required port, a running ghost process, a misconfiguration or a XAMPP installation issue.

    • WikiAdmin
    • 09.01.2021 11:50 edited
  3. Re: Suddenly A New Problem

    Restarting XAMPP or any of its components did not solve anything
    Firewall or security is not the issue.
    The link is for Windows 8, I'm on 10

    I re-installed Wacko just fine. No issues.
    I tried to log in with the admin account I just made and it told me the username was invalid.
    I went back to localhost/wiki and tried again, and this is where it gives me the "timed out" message as seen above.
    There is nothing in any of the logs that indicate an error.
    The front page has also changed. Let me start over and I will grab screen shots this time.
  4. Re: Suddenly A New Problem


    I don't know why it's not working, and I am almost done trying.
    • Breantique
    • 08.01.2022 18:04 edited
  5. Re: Chosen user name is invalid

    Please remove the underline from your admins username in the installer, then you should be able to login, e.g. FfAdmin or ffadmin.

    The installer does not validate the username against the name pattern, hence it allowed you to insert an underscore in the name.
    However the login action validates the username against the allowed pattern. The username must be between 3 and 20 chars long and use only alphanumeric characters. Upper case characters are OK.

    Chosen user name is invalid.
    The underscore is not allowed because the username becomes part of the wiki namespace and of the build in urls_underscores option.

    The connection has timed out
    If a user tries to login with wrong credentials, it triggers the function log_user_delay() to mitigate automated brute force attempts.
    That might have lead to the connection time out.

    1. validate the username also in the installer against the allowed patterns. DONE Patch
    2. add non JS form validation
    • WikiAdmin
    • 11.01.2021 15:29 edited
Log in or create an account to post a comment.