View Issue Details

IDProjectCategoryView StatusLast Update
0000291WackoWikicorepublic2011-05-31 23:25
ReporterTann SanAssigned Toadministrator 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version5.4.0 
Target Version5.0.betaFixed in Version5.0.beta 
Summary0000291: have a special namespace for user pages
DescriptionHave all user pages as sub pages of the current Users page.

At the moment, each users personal page is a main root page. It would be alot nicer if they were all listed under the Users page. This would make the page index more meaningful for one thing as well as just make the system look a bit smoother. We should also make it so that it is impossible for a user to create a page manually, under the Users page (except comments).

This ties in with the "Automatically Create User Page Upon Registration" feature request.

We could make it so that when the system is called with page=WackoAdmin it first looks through the root pages like it does at the moment. If it isn't located it then searches under the Users page. That way we get to use both old and new style name links.

A users page can be overwritten by a page in root with the same name. Not overwritten as in replaced but all links that previously linked to a users WikiName would then switch to loading the page in root with the same name. We could circumvent this issue by preventing root pages from being created if they match any current WikiNames. We already do this for when their is another root page with the same name. We just need to update the "Page already exists" message to indicate it could be already used as a WikiName. We should check which is the case and have a totally seperate error page for each case.
TagsNo tags attached.

Relationships

duplicate of 0000343 resolvedadministrator Dedicated cluster for user profiles 
related to 0000052 resolvedadministrator Automatically create user page on registration 
related to 0000108 assignedadministrator redirect to personal page / page visited before login 
parent of 0000351 resolvedadministrator add user profile action 
related to 0000342 resolvedadministrator Non-wiki nicknames 
child of 0000352 confirmed Wacko-powered forum 

Activities

administrator

2009-12-13 16:52

administrator   ~0000735

Last edited: 2009-12-13 17:24

View 3 revisions

lets implement this with the new user (profile) action
-> http://test.wackowiki.org/News/2009/December/NewUsersAction

config: "users_page" => "PageNameHere", - default page containing the users action

administrator

2011-02-16 10:50

administrator   ~0000780

this feature is now mainly implemented:
1. macro -> :::: now shows to ((user:username username))
2. registration: a new userpage will be created in the usernamespace
3. added migration action to move all user pages into the new usernamespace
4. ...

Issue History

Date Modified Username Field Change
2009-04-10 13:48 Tann San New Issue
2009-04-10 13:48 Tann San Relationship added related to 0000052
2009-07-07 15:52 administrator Status new => acknowledged
2009-07-07 15:52 administrator Summary Have all user pages as sub pages of the current Users page. => have a special namespace for user pages
2009-07-07 15:52 administrator Description Updated View Revisions
2009-10-10 21:44 administrator Target Version => 7.0.x
2009-10-28 04:15 administrator Relationship added duplicate of 0000343
2009-10-28 04:21 administrator Relationship added related to 0000342
2009-12-13 16:52 administrator Note Added: 0000735
2009-12-13 17:16 administrator Relationship added parent of 0000351
2009-12-13 17:20 administrator Note Edited: 0000735 View Revisions
2009-12-13 17:24 administrator Note Edited: 0000735 View Revisions
2010-02-22 17:40 Freeman Relationship added child of 0000352
2010-03-08 10:12 administrator Category Core => core
2011-02-16 10:50 administrator Note Added: 0000780
2011-02-16 10:50 administrator Assigned To => administrator
2011-02-16 10:50 administrator Status acknowledged => resolved
2011-02-16 10:50 administrator Resolution open => fixed
2011-02-16 10:50 administrator Fixed in Version => 5.0.beta
2011-02-16 10:50 administrator Target Version 7.0.x => 5.0.0
2011-02-16 10:55 administrator Relationship added related to 0000108
2011-05-31 23:25 administrator Target Version 5.0.0 => 5.0.beta