View Issue Details

IDProjectCategoryView StatusLast Update
0000330WackoWikilocalizationpublic2011-12-04 06:36
ReporterAbram4 Assigned Toadministrator  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.rc 
Target Version5.0.betaFixed in Version5.0.beta 
Summary0000330: Wrong sorting pages named in Russian on Index page.
DescriptionPages with russian names sorted in strange order , not in А-Я ордер.
Additional InformationTested on Index pages:
http://test.wackowiki.org/PageIndex (set as latin1_swedish_ci)
http://wackowiki.org/PageIndex (set as latin1_swedish_ci)
and localhost test installation.
TagsNo tags attached.

Relationships

duplicate of 0000053 resolvedTann San PageIndex sort wrong with capital ans non capital Letters 
duplicate of 0000403 closedadministrator incorrect letter index order in katalog 
related to 0000376 resolvedadministrator Page Index with "not german" characters 

Activities

administrator

2009-10-03 20:45

administrator   ~0000681

Last edited: 2011-12-28 11:11

View 2 revisions

did you a fresh install or an update

guess till we don't have utf8 we run one way or the other into this trouble

e.g. see /setup/database_mysql_update.php search for COLLATE or CHARACTER SET
http://wackowiki.hg.sourceforge.net/hgweb/wackowiki/stable/file/tip/wacko/setup/database_mysql_updates.php

I already removed this again from database_mysql.php - but will it work without ...

administrator

2009-10-03 20:53

administrator   ~0000682

Last edited: 2009-10-03 21:01

View 4 revisions

btw. can you take also a look at the config setting

"db_collation" => "0"
this should affect the "ORDER BY" clause
http://dev.mysql.com/doc/refman/5.1/en/charset-charsets.html

try it with charset for Russian instead of "0"

administrator

2009-10-04 14:55

administrator   ~0000683

UPD svn rev662

Abram4

2009-10-05 17:27

updater   ~0000684

Thank you very much.
After full reinstalling with the new file database_mysql_updates.php from svn rev662 pages with Russian names are ordered as expected.

Issue History

Date Modified Username Field Change
2009-10-03 20:26 Abram4 New Issue
2009-10-03 20:45 administrator Note Added: 0000681
2009-10-03 20:46 administrator Status new => acknowledged
2009-10-03 20:46 administrator Additional Information Updated View Revisions
2009-10-03 20:53 administrator Note Added: 0000682
2009-10-03 20:53 administrator Note Edited: 0000682 View Revisions
2009-10-03 20:54 administrator Note Edited: 0000682 View Revisions
2009-10-03 21:01 administrator Note Edited: 0000682 View Revisions
2009-10-03 21:20 administrator Target Version => 5.0.0
2009-10-03 21:39 administrator Additional Information Updated View Revisions
2009-10-04 14:55 administrator Note Added: 0000683
2009-10-05 17:27 Abram4 Note Added: 0000684
2009-10-05 19:07 administrator Assigned To => administrator
2009-10-05 19:07 administrator Resolution open => fixed
2009-10-05 19:07 administrator Fixed in Version => 5.0.0
2009-10-05 19:07 administrator Status acknowledged => resolved
2009-10-10 21:27 administrator Relationship added duplicate of 0000053
2009-10-13 15:58 administrator Target Version 5.0.0 => 5.0.beta
2009-10-13 16:03 administrator Fixed in Version 5.0.0 => 5.0.beta
2010-03-08 10:16 administrator Category Localization => localization
2011-12-04 06:34 administrator Relationship added duplicate of 0000403
2011-12-04 06:36 administrator Relationship added related to 0000376
2011-12-28 11:11 administrator Note Edited: 0000681 View Revisions