View Issue Details

IDProjectCategoryView StatusLast Update
0000342WackoWikicorepublic2011-09-12 11:53
ReporterFreeman Assigned Toadministrator  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Target Version5.0.rcFixed in Version5.0.rc 
Summary0000342: Non-wiki nicknames
DescriptionWackoWiki should allow to register users with traditional nicknames, not forced NameSurname. Wiki- and tikiwiki-links can be disabled by admin, and non-wiki nicknames would be relevant to make this feature complete.

config['disable_wikiname']

0 - enforce WikiName
1 - off
Additional Information// check if name is WikiName style
if (!$this->is_wiki_name($user_name) && $this->config['disable_wikiname'] === false)
{
...
}
TagsNo tags attached.

Relationships

related to 0000291 resolvedadministrator have a special namespace for user pages 
related to 0000352 confirmed Wacko-powered forum 
related to 0000387 resolvedadministrator disable tikilinks and wikilinks by default 
related to 0000317 resolvedadministrator add option: disable autolinks to config 

Activities

administrator

2009-10-28 04:20

administrator   ~0000722

ToDo: What could go wrong if we do this and how we can address it?

Freeman

2009-11-05 13:56

developer   ~0000726

I prefer to use non-wikiwords, especially for "systems" page names (e.g., PageIndex is called Oversigt). In my opinion, CamelCase words are OK, but the space between words makes them "ugly". (maybe should be switched off as default?)
© John Gøtze (http://wackowiki.org/Dev/Translations/da)

administrator

2011-03-31 11:51

administrator   ~0000789

http://wackowiki.hg.sourceforge.net/hgweb/wackowiki/stable/rev/ef9c8336bed0

administrator

2011-09-10 13:09

administrator   ~0000810

Last edited: 2011-09-10 16:16

View 9 revisions

I reopend this issue because if config['disable_wikiname'] is set true
the username must at least fit the page tag naming conventions but without \-\'\_\.
as long as the user_name is used for login and the user name space.

$this->language['ALPHANUM_P']

additionally the user_name lenght should be checked

field size is VARCHAR(80)
so I suggest to set the default values for
username_chars_min = 3
username_chars_max = 20

administrator

2011-09-12 11:52

administrator   ~0000811

Last edited: 2011-09-12 11:52

View 2 revisions

http://wackowiki.hg.sourceforge.net/hgweb/wackowiki/stable/rev/a54360448f7c

further improvements needed -> R6.0 and unicode

Issue History

Date Modified Username Field Change
2009-10-25 17:26 Freeman New Issue
2009-10-28 04:20 administrator Note Added: 0000722
2009-10-28 04:20 administrator Status new => feedback
2009-10-28 04:21 administrator Relationship added related to 0000291
2009-10-28 04:22 administrator Target Version => 5.4.0
2009-11-05 13:56 Freeman Note Added: 0000726
2010-02-22 18:04 Freeman Relationship added related to 0000352
2010-03-08 10:12 administrator Category Core => core
2011-03-31 09:53 administrator Assigned To => administrator
2011-03-31 09:53 administrator Status feedback => assigned
2011-03-31 09:53 administrator Target Version 5.4.0 => 5.0.beta
2011-03-31 10:11 administrator Description Updated View Revisions
2011-03-31 10:11 administrator Additional Information Updated View Revisions
2011-03-31 11:51 administrator Note Added: 0000789
2011-03-31 11:51 administrator Status assigned => resolved
2011-03-31 11:51 administrator Resolution open => fixed
2011-03-31 11:51 administrator Fixed in Version => 5.0.beta
2011-03-31 11:51 administrator Description Updated View Revisions
2011-05-31 21:24 administrator Build => R5.0.beta
2011-07-03 12:17 administrator Relationship added related to 0000387
2011-07-03 12:18 administrator Relationship added related to 0000317
2011-09-04 13:07 administrator Status resolved => assigned
2011-09-04 13:07 administrator Resolution fixed => reopened
2011-09-04 13:07 administrator Target Version 5.0.beta => 4.3.rc
2011-09-04 13:08 administrator Fixed in Version 5.0.beta =>
2011-09-04 13:09 administrator Target Version 4.3.rc => 5.0.rc
2011-09-10 13:09 administrator Note Added: 0000810
2011-09-10 13:10 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:15 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:16 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:17 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:18 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:18 administrator Note Edited: 0000810 View Revisions
2011-09-10 13:20 administrator Note Edited: 0000810 View Revisions
2011-09-10 16:16 administrator Note Edited: 0000810 View Revisions
2011-09-12 11:52 administrator Note Added: 0000811
2011-09-12 11:52 administrator Note Edited: 0000811 View Revisions
2011-09-12 11:53 administrator Status assigned => resolved
2011-09-12 11:53 administrator Resolution reopened => fixed
2011-09-12 11:53 administrator Fixed in Version => 5.0.rc