View Issue Details

IDProjectCategoryView StatusLast Update
0000090WackoWikiappearancepublic2012-03-11 17:03
ReporterTann San Assigned Toadministrator  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version4.2 
Target Version5.0.0Fixed in Version5.0.0 
Summary0000090: Per Page / Cluster Themes
DescriptionThe idea being that we can assign a global default theme which is how it is now and then in each pages setup section we can specify a different theme. This could be applied just to that page or it can be recursive down that pages entire branch of child pages.
Additional InformationTheme(s) per page / cluster

It would be nice to have this sort of functionality with the wiki. We can add it to the admin page for each page. At the moment we can only set the theme either as the admin in a global fashion or on a per-user level. I think it would be cool if it worked like this.

During installation (and later on via the config file) the site admin specifies a default theme. All pages use this until the admin (or anyone with page editing rights) changes a pages theme via the page admin section. At that point they can pick whether to change the theme for just that page or all of it's children pages as well. We already have the "just this page or all it's kids" functionality for other options.

On the users personal config page they should still get the "Theme" dropdown like they currently do but the default item will be "Site Default". If the admin allows them to choose their own theme then what they pick here will over-rite the site default. On the other hand if the admin decides they don't want users to pick their own theme then we hide the dropdown.

This allows the wiki to be used in totally new ways or more likely enhances it's current abilities. Say someone has a site that has 3 main branches. One for John, one for Julie and one for Frank. They each maintain their own branches. Now they can each have their own theme(s). There's way more uses but I'll leave it up to your imagination for these :¬)
TagsNo tags attached.

Relationships

related to 0000197 assignedElar9000 XML-RPC - Web service with open protocol 

Activities

administrator

2008-07-16 16:24

administrator   ~0000415

Tann San:
How about having page logos. Each page can have an "icon" section on it's setting page. You can upload an image to use as a kind of page avatar. All child pages inherit that image unless they have their icon set to "blank" or have their own icon uploaded. I'm not really sure how we would use the icon/logo though. :¬)

Freeman

2008-07-22 15:51

developer   ~0000420

Wiki looks like Christmas tree? No, it's not a good idea.

administrator

2008-07-22 17:00

administrator   ~0000421

there are usage scenarios where this is desirable
imagine a faculty with several departments sharing a wiki -> clusters

Tann San

2008-07-22 17:03

manager   ~0000422

Where did you get Christmas tree from?

Freeman

2008-07-22 19:35

developer   ~0000423

> imagine a faculty with several departments sharing a wiki -> clusters
Discharge IT-manager, stage manager or system administrator, forced to share same wiki with several projects.

> Where did you get Christmas tree from?
Here. Mindless entity duplication without of decomposition and inheritance decreases manageability and reliability.

What is the WackoWiki-driven site now? This is a set of hierarchy-organized pages (of knowledge). All the pages linked logically and semantically as we can treat them as single and consistent entity. Thus, task described above is incorrect. To solve it, John, Julie and Frank should create 3 different wikies, put each other into custom interwiki list and call them via interwiki links. We already have a tool to solve the task without entity duplication.

WackoWiki has clear concepts, we should carefully keep them and multiply when possible, and protect against bad solutions and feature-ism.

Tann San

2008-07-22 22:50

manager   ~0000428

That's just one scenario. Let's take another one.

You have a university which uses the wiki for their main site. They want all the pages to have a similar layout i.e. navigation, header and text formatting scheme. Each department; Engineering, Computing and Languages should have a different background color and possibly different text color scheme (but not different text formatting i.e. font sizes and styles). My old Universities site worked this way.

Without a custom hack or having four seperate wacko installs they cannot currently do this. The fourth install is the main sites theme btw.

Freeman

2008-07-23 23:21

developer   ~0000431

For University purposes? Hmm, I'll think about it.

Freeman

2008-07-27 21:03

developer   ~0000442

Same idea on WackoIdeas: http://wackowiki.com/WackoIdeas#h4057-55 (Russian)

Translated by me:

More design?
Separate themes for cluster, possibility of setting.
GlebBorisovich (ГлебБорисович)

Hmm, when more than one man thinking about the same, it's not a bad idea?

administrator

2011-01-02 21:55

administrator   ~0000778

basic changes were implemented:

now we have
1. global theme
2. page theme
3. user theme

a new field 'theme' where added to the 'page' table

config setting: allow_themes_per_page = [0|1] (default = 0 (off), change the value via config table or the Admin panel)

for now the page theme (if set) overrides the user theme, to reset the page theme choose [--] this will reset the value for the page theme to NULL

ToDo:
- inheritence
- change theme for entire cluster
- user setting: theme_per_page overrides user_theme [0|1]

you can test it here
http://test.wackowiki.org/HomePage
go to page properties and change the theme (of your own page)

administrator

2011-06-16 09:39

administrator   ~0000796

Last edited: 2012-03-11 17:02

View 2 revisions

http://wackowiki.sourceforge.net/test/News/2011/06/PerPageSettings

Issue History

Date Modified Username Field Change
2007-09-25 09:37 Tann San New Issue
2007-09-25 09:37 Tann San Legacy => NEW
2008-04-14 12:01 administrator Additional Information Updated
2008-07-16 15:52 administrator Summary Per Page Themes => Per Page Themes / Cluster
2008-07-16 16:24 administrator Note Added: 0000415
2008-07-16 16:25 administrator Status new => acknowledged
2008-07-22 15:51 Freeman Note Added: 0000420
2008-07-22 17:00 administrator Note Added: 0000421
2008-07-22 17:00 administrator Summary Per Page Themes / Cluster => Per Page / Cluster Themes
2008-07-22 17:03 Tann San Note Added: 0000422
2008-07-22 19:35 Freeman Note Added: 0000423
2008-07-22 22:29 Tann San Relationship added related to 0000197
2008-07-22 22:50 Tann San Note Added: 0000428
2008-07-23 23:21 Freeman Note Added: 0000431
2008-07-27 21:03 Freeman Note Added: 0000442
2010-03-08 10:10 administrator Category Appearance => appearance
2011-01-02 21:37 administrator Assigned To => administrator
2011-01-02 21:37 administrator Status acknowledged => assigned
2011-01-02 21:37 administrator Target Version => 5.0.0
2011-01-02 21:55 administrator Note Added: 0000778
2011-06-16 09:39 administrator Note Added: 0000796
2012-03-11 17:02 administrator Note Edited: 0000796 View Revisions
2012-03-11 17:03 administrator Status assigned => resolved
2012-03-11 17:03 administrator Resolution open => fixed
2012-03-11 17:03 administrator Fixed in Version => 5.0.0